Bug 1101194 - JeOS-efi: Initramfs unpacking failed: junk in compressed archive
JeOS-efi: Initramfs unpacking failed: junk in compressed archive
Status: RESOLVED DUPLICATE of bug 1104833
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
armv7 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-13 17:25 UTC by Matwey Kornilov
Modified: 2019-02-14 15:01 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matwey Kornilov 2018-07-13 17:25:10 UTC
Hello,

I am running openSUSE-Tumbleweed-ARM-JeOS-efi.armv7l-2018.07.08-Build1.1.raw and I see the following

[    0.792459] Initramfs unpacking failed: junk in compressed archive
[    1.110213] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    1.110792] CPU: 0 PID: 1 Comm: swapper/0 Not tainted 4.17.4-1-default #1 openSUSE Tumbleweed (unreleased)
[    1.111066] Hardware name: Generic DT based system
[    1.111830] [<c0321000>] (unwind_backtrace) from [<c0319640>] (show_stack+0x20/0x28)
[    1.112063] [<c0319640>] (show_stack) from [<c0de2418>] (dump_stack+0xb8/0xe4)
[    1.112275] [<c0de2418>] (dump_stack) from [<c036c168>] (panic+0xf0/0x28c)
[    1.112488] [<c036c168>] (panic) from [<c15018e8>] (mount_block_root+0x26c/0x31c)
[    1.112701] [<c15018e8>] (mount_block_root) from [<c1501a2c>] (mount_root+0x94/0x98)
[    1.112877] [<c1501a2c>] (mount_root) from [<c1501b90>] (prepare_namespace+0x160/0x1a8)
[    1.113054] [<c1501b90>] (prepare_namespace) from [<c150141c>] (kernel_init_freeable+0x42c/0x440)
[    1.113256] [<c150141c>] (kernel_init_freeable) from [<c0df74c4>] (kernel_init+0x18/0x128)
[    1.113441] [<c0df74c4>] (kernel_init) from [<c03010ac>] (ret_from_fork+0x14/0x28)
[    1.113642] Exception stack(0xeb131fb0 to 0xeb131ff8)
[    1.113830] 1fa0:                                     00000000 00000000 00000000 00000000
[    1.114012] 1fc0: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[    1.114191] 1fe0: 00000000 00000000 00000000 00000000 00000013 00000000
[    1.114794] CPU1: stopping
[    1.115221] CPU: 1 PID: 0 Comm: swapper/1 Not tainted 4.17.4-1-default #1 openSUSE Tumbleweed (unreleased)
[    1.115809] Hardware name: Generic DT based system
[    1.116158] [<c0321000>] (unwind_backtrace) from [<c0319640>] (show_stack+0x20/0x28)
[    1.116659] [<c0319640>] (show_stack) from [<c0de2418>] (dump_stack+0xb8/0xe4)
[    1.117132] [<c0de2418>] (dump_stack) from [<c031d5ac>] (handle_IPI+0x338/0x360)
[    1.117604] [<c031d5ac>] (handle_IPI) from [<c0302c40>] (gic_handle_irq+0x98/0x9c)
[    1.118085] [<c0302c40>] (gic_handle_irq) from [<c030203c>] (__irq_svc+0x5c/0x94)
[    1.118544] Exception stack(0xeb171f18 to 0xeb171f60)
[    1.118869] 1f00:                                                       00000000 00000000
[    1.119369] 1f20: 2e28e000 20000093 ffffe000 c1705db8 c1705e08 00000002 00000000 c1705e24
[    1.119871] 1f40: 00000000 eb171f74 eb171f68 eb171f68 c0315a8c c0315a90 20000013 ffffffff
[    1.120378] [<c030203c>] (__irq_svc) from [<c0315a90>] (arch_cpu_idle+0x54/0x5c)
[    1.120848] [<c0315a90>] (arch_cpu_idle) from [<c0dfd854>] (default_idle_call+0x40/0x48)
[    1.121400] [<c0dfd854>] (default_idle_call) from [<c03a0b48>] (do_idle+0x1f0/0x290)
[    1.121932] [<c03a0b48>] (do_idle) from [<c03a0ec4>] (cpu_startup_entry+0x28/0x2c)
[    1.122421] [<c03a0ec4>] (cpu_startup_entry) from [<c031cfc4>] (secondary_start_kernel+0x17c/0x1a8)
[    1.123269] [<c031cfc4>] (secondary_start_kernel) from [<403034ac>] (0x403034ac)
[    1.124490] Rebooting in 90 seconds..

This is surprising because initrd contained in disk image seems to be valid XZ compressed CPIO.
Comment 1 Matwey Kornilov 2018-07-29 09:13:57 UTC
This is probably OVMF issue.

When running as

qemu-system-aarch64 -M virt --cpu cortex-a15 -kernel zImage  -initrd initrd -serial stdio -m 512 -display none -append "console=ttyAMA0 loglevel=8"

then the kernel boots and deploy initrd successfully.

I am running

qemu-uefi-aarch32-2018+git1531464032.ae08ea246fe9-1.1.noarch

and

qemu-2.11.1
Comment 2 Guillaume GARDET 2019-02-13 15:53:41 UTC
Closing as duplicate of bug 1104833

*** This bug has been marked as a duplicate of bug 1104833 ***