Bug 1101119 - Regression: bluetooth headset not connecting after resume from suspend.
Regression: bluetooth headset not connecting after resume from suspend.
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Basesystem
Leap 15.0
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Al Cho
E-mail List
:
Depends on: 1076898
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-13 06:56 UTC by Cedric Devillers
Modified: 2018-11-17 23:46 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cedric Devillers 2018-07-13 06:56:26 UTC
+++ This bug was initially created as a clone of Bug #1076898 +++

it seems that the exact same problem that was fixed in tumbleweed is present in leap 15.0.

After resuming from suspend, bluetooth headset is not able to be used anymore. A workaround is to restart bluetooth service.

I've tried the exact same patch as on tumbleweed : https://build.opensuse.org/request/show/575499 and now it's working fine on my system, headset is reconnecting without the need to restart the service.

Also it seems that the patch was later dropped because bluez was fixed upstream.

Please consider patching bluez on leap 15.0 updates to fix this.
Comment 1 Stefan Seyfried 2018-07-13 09:10:05 UTC
ok.
Comment 2 Stefan Seyfried 2018-07-13 09:35:02 UTC
https://build.opensuse.org/request/show/622447

note that it is possible that this fix needs to go into SLES15 first and then will be inherited from there, so if this request is rejected, this does not necessarily mean the Update is rejected ;-)
Comment 3 Andreas Stieger 2018-07-13 10:18:31 UTC
Thanks Stefan. Merged into SLE maintenance. Assign to SLE maintainer.
Comment 5 Swamp Workflow Management 2018-07-13 11:00:10 UTC
This is an autogenerated message for OBS integration:
This bug (1101119) was mentioned in
https://build.opensuse.org/request/show/622457 15.0 / bluez
Comment 6 Swamp Workflow Management 2018-07-20 01:11:38 UTC
openSUSE-RU-2018:2017-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1094902,1101119,995059
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    bluez-5.48-lp150.4.3.1
Comment 7 Swamp Workflow Management 2018-08-13 19:08:03 UTC
SUSE-RU-2018:2314-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1094902,1101119,995059
CVE References: 
Sources used:
SUSE Linux Enterprise Workstation Extension 15 (src):    bluez-5.48-5.5.2
SUSE Linux Enterprise Module for Desktop Applications 15 (src):    bluez-5.48-5.5.2
SUSE Linux Enterprise Module for Basesystem 15 (src):    bluez-5.48-5.5.2