Bug 1101107 - trackerbug: packages do not build reproducibly from including kernel version
trackerbug: packages do not build reproducibly from including kernel version
Status: IN_PROGRESS
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
All openSUSE Factory
: P5 - None : Minor (vote)
: ---
Assigned To: Bernhard Wiedemann
E-mail List
:
Depends on: 1173918
Blocks: 1081754
  Show dependency treegraph
 
Reported: 2018-07-13 02:55 UTC by Bernhard Wiedemann
Modified: 2022-03-15 23:05 UTC (History)
0 users

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Wiedemann 2018-07-13 02:55:38 UTC
See also https://reproducible-builds.org/

When packages include the kernel version from the build system
it results in binaries that sometimes differ
and thus trigger rebuilds of depending packages
and are published to mirrors and users
when actually nothing really changed.

To reproduce locally, do one build with
osc build --vm-type=kvm
and another with
osc build --vm-type=lxc
Comment 3 Swamp Workflow Management 2018-09-28 16:09:27 UTC
SUSE-RU-2018:2936-1: An update that has two recommended fixes can now be installed.

Category: recommended (important)
Bug References: 1101107,1101600
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Server Applications 15 (src):    pidentd-3.0.19-3.3.1
Comment 4 Swamp Workflow Management 2018-09-29 19:08:06 UTC
openSUSE-RU-2018:2947-1: An update that has two recommended fixes can now be installed.

Category: recommended (important)
Bug References: 1101107,1101600
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    pidentd-3.0.19-lp150.3.3.1