Bug 1100844 - 'zypper pa --unneeded' does not report packages in presence of an appplication
'zypper pa --unneeded' does not report packages in presence of an appplication
Status: RESOLVED DUPLICATE of bug 1104415
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: libzypp
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-11 08:23 UTC by Michael Andres
Modified: 2018-08-10 07:00 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Andres 2018-07-11 08:23:42 UTC
---[reported via mail]---

linux-n6xo:/home/pantelis # zypper pa --unneeded
Loading repository data...
Reading installed packages...
No packages found.
 
 
 
linux-n6xo:/home/pantelis # zypper in gwenview
Loading repository data...
Reading installed packages...
'gwenview' not found in package names. Trying capabilities.
Resolving package dependencies...
The following 9 NEW packages are going to be installed:
  gwenview5 gwenview5-lang libKF5Activities5 libKF5ItemModels5 libKF5KDcraw5
  libKF5Kipi32_0_0 libKF5Parts5 libKF5Parts5-lang libkipi-data
The following 2 recommended packages were automatically selected:
  gwenview5-lang libKF5Parts5-lang
9 new packages to install.
Overall download size: 8.0 MiB. Already cached: 0 B. After the operation,
additional 12.2 MiB will be used.
Continue? [y/n/...? shows all options] (y):
 
 
 
linux-n6xo:/home/pantelis # zypper se -s -i gwenview
Loading repository data...
Reading installed packages...
S  | Name           | Type        | Version     | Arch   | Repository             
---+----------------+-------------+-------------+--------+------------------------
i  | Gwenview       | application |             | noarch | openSUSE-Tumbleweed-Oss
i+ | gwenview5      | package     | 18.04.2-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
i  | gwenview5-lang | package     | 18.04.2-1.1 | noarch | openSUSE-Tumbleweed-Oss
 
 
 
AFTER ADDING gwenview to /var/lib/zypp/AutoInstalled
linux-n6xo:/home/pantelis # zypper se -s -i gwenview
Loading repository data...
Reading installed packages...
S | Name           | Type        | Version     | Arch   | Repository             
--+----------------+-------------+-------------+--------+------------------------
i | Gwenview       | application |             | noarch | openSUSE-Tumbleweed-Oss
i | gwenview5      | package     | 18.04.2-1.1 | x86_64 | openSUSE-Tumbleweed-Oss
i | gwenview5-lang | package     | 18.04.2-1.1 | noarch | openSUSE-Tumbleweed-Oss
 
 
 
AS YOU SEE IT DOES NOT PROMPT TO REMOVE UNNEEDED PACKAGES
linux-n6xo:/home/pantelis # zypper pa --unneeded
Loading repository data...
Reading installed packages...
No packages found.
 
 
 
THIS IS NOT CASE IF YOU INSTALL A PACKAGE THAT DO NOT INSTALL AN APPLICATION TYPE
Comment 1 Michael Andres 2018-08-10 07:00:18 UTC
duplicate

*** This bug has been marked as a duplicate of bug 1104415 ***