Bug 1100786 - "rsync" or its dependencies pull in even systemd and dracut and systemd-presets-branding-CAASP (useless in containers at least)
"rsync" or its dependencies pull in even systemd and dracut and systemd-prese...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Pedro Monreal Gonzalez
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-10 17:39 UTC by Oliver Kurz
Modified: 2019-07-16 10:14 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Kurz 2018-07-10 17:39:10 UTC
## Observation

It seems some packages have heavy dependencies even without recommends, e.g. rsync or its dependencies depend on systemd+dracut


```
$ docker run -it --rm opensuse/tumbleweed sh -c 'zypper -n in --no-recommends rsync'
Retrieving repository 'openSUSE-Tumbleweed-Non-Oss' metadata .............................................[done]Building repository 'openSUSE-Tumbleweed-Non-Oss' cache ..................................................[done]
Retrieving repository 'openSUSE-Tumbleweed-Oss' metadata .................................................[done]
Building repository 'openSUSE-Tumbleweed-Oss' cache ......................................................[done]
Retrieving repository 'openSUSE-Tumbleweed-Update' metadata ..............................................[done]
Building repository 'openSUSE-Tumbleweed-Update' cache ...................................................[done]
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 34 NEW packages are going to be installed:
  blog dbus-1 dracut elfutils file hardlink kbd kbd-legacy kmod kmod-compat libapparmor1 libargon2-1 libasm1
  libcryptsetup12 libdbus-1-3 libdevmapper1_03 libexpat1 libjson-c4 libkmod2 libqrencode4 libseccomp2 openslp
  pam-config pigz pkg-config rsync suse-module-tools systemd systemd-presets-branding-CAASP
  systemd-presets-common-SUSE systemd-sysvinit sysvinit-tools udev xz
```

## Steps to reproduce

See above docker command to reproduce. I assume one can also use a minimal package self-test where a "BuildRequires: rsync" shows what is pulled in.


## Further details

See also https://bugzilla.opensuse.org/show_bug.cgi?id=980389
Comment 1 Thorsten Kukuk 2018-07-11 13:08:08 UTC
The systemd requires is not really needed, the pre/post scripts can scope fine with the fact if systemd is not there, and since we fixed the systemd-preset packages, there is no need anymore to install systemd first.

SR#622085
Comment 2 Tomáš Chvátal 2018-07-12 18:23:52 UTC
As the submission is in process we can right away also close the bug.
Comment 3 Oliver Kurz 2018-07-13 13:09:52 UTC
https://build.opensuse.org/request/show/622088 is the according submission to openSUSE:Factory. Thanks all, that was quick :)
Comment 4 Swamp Workflow Management 2019-04-26 09:30:46 UTC
This is an autogenerated message for OBS integration:
This bug (1100786) was mentioned in
https://build.opensuse.org/request/show/698102 15.1 / rsync
https://build.opensuse.org/request/show/698104 15.0 / rsync
Comment 6 Swamp Workflow Management 2019-05-27 16:10:27 UTC
SUSE-RU-2019:1358-1: An update that has two recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1100786,1108562
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Basesystem 15 (src):    rsync-3.1.3-4.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2019-06-03 10:15:45 UTC
openSUSE-RU-2019:1489-1: An update that has two recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1100786,1108562
CVE References: 
Sources used:
openSUSE Leap 15.1 (src):    rsync-3.1.3-lp151.4.3.1
openSUSE Leap 15.0 (src):    rsync-3.1.3-lp150.3.3.1
Comment 9 Swamp Workflow Management 2019-07-16 10:14:56 UTC
SUSE-RU-2019:1358-2: An update that has two recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1100786,1108562
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Basesystem 15-SP1 (src):    rsync-3.1.3-4.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.