Bug 1100759 - Periodic black screen at radeon
Periodic black screen at radeon
Status: RESOLVED INVALID
: 1106635 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-10 14:20 UTC by Matej Cepl
Modified: 2018-11-15 16:35 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
sndirsch: needinfo? (mcepl)


Attachments
output of journalctl -xb (316.98 KB, text/plain)
2018-07-10 14:20 UTC, Matej Cepl
Details
output of dmesg (75.77 KB, text/plain)
2018-07-10 14:20 UTC, Matej Cepl
Details
dmesg output (10.45 KB, text/plain)
2018-08-15 14:46 UTC, Robert Mahar
Details
lspci output for both GPU cards (7.45 KB, text/plain)
2018-08-15 14:47 UTC, Robert Mahar
Details
Xorg.log output (56.14 KB, text/plain)
2018-08-15 14:48 UTC, Robert Mahar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matej Cepl 2018-07-10 14:20:12 UTC
Created attachment 776579 [details]
output of journalctl -xb

Quite often (at this moment, I have even problems to finish this bug report, but normally it was just around five times daily) the screen gets black. All programs run (e.g., YouTube in Firefox is still playing), but I haven't found a way how to get screen reinitialized (Ctrl-Alt-F2 and similar do nothing).
Comment 1 Matej Cepl 2018-07-10 14:20:53 UTC
Created attachment 776580 [details]
output of dmesg

I am not sure whether it is still good for anything.
Comment 2 Takashi Iwai 2018-07-13 14:36:47 UTC
It looks like a GPU lockup and the failing recover after that.
Is this a regression from the older versions?
Comment 3 Matej Cepl 2018-07-16 10:30:56 UTC
(In reply to Takashi Iwai from comment #2)
> It looks like a GPU lockup and the failing recover after that.
> Is this a regression from the older versions?

Hard to say, I have this computer only since May (always with Tumbleweed), and I have SOME problems almost from start. However, it got SERIOUSLY worse lately. Now it is on the edge of unuseability.
Comment 4 Takashi Iwai 2018-07-23 13:05:14 UTC
Does the problem persist with the latest 4.17.7?  There have been unstable things on 4.17.x, and most of issues have been addressed there.

Just to be sure.
Comment 5 Matej Cepl 2018-07-23 13:06:32 UTC
(In reply to Takashi Iwai from comment #4)
> Does the problem persist with the latest 4.17.7?  There have been unstable
> things on 4.17.x, and most of issues have been addressed there.
> 
> Just to be sure.

It seems to be better last couple of days. I haven't had any crash so far. Currently on 4.18.0-rc5-2.g019b534-default
Comment 6 Takashi Iwai 2018-07-23 13:32:57 UTC
OK, let's cross fingers :)
Comment 7 Matej Cepl 2018-07-26 07:00:09 UTC
Happened to me against twice in line on Tuesday. Auch.
Comment 8 Takashi Iwai 2018-07-30 13:37:08 UTC
If it's still failing with the latest upstream, could you try to report the issue to upstream?  Feel free to put me (tiwai@suse.de) in Cc, if it's for bugzilla.freedesktop.org.  Thanks.
Comment 9 Robert Mahar 2018-08-15 14:42:12 UTC
Started seeing similar looking GPU crash just after logging in, or when trying to start first application after GUI initialized.  It may be this bug.

https://bugs.freedesktop.org/show_bug.cgi?id=105381

Patches have been committed on their end, however I cannot determine if the referenced patches to the radeon driver have percolated down to Tumbleweed yet.

In my case I have two servers, both with AMD R5 A220 cards, one with two of them in a dual monitor configuration.   Both started exhibiting strange behavior after patching over the weekend. It may have been 3 weeks since last zypper dup.   Anyway, when the GUI initializes, there is a few second period of "snow" / "static" that appears prior to greeter showing up.  This was not present previously.  Once you login, it will usually hang during the spinner prior to KDE appearing.  You can see both monitors flashing, going black.  If you do get a GUI, pretty much the next app you start cuases it to throw GPU crash messages and that desktop effects will be disabled.   Similar hallmarks appear in the logs.  ( identical to the referenced bug ) 

I just can't tell if the fix has made it into the Tumbleweed patch repo yet.
Comment 10 Robert Mahar 2018-08-15 14:46:35 UTC
Created attachment 779801 [details]
dmesg output
Comment 11 Robert Mahar 2018-08-15 14:47:32 UTC
Created attachment 779802 [details]
lspci output for both GPU cards
Comment 12 Robert Mahar 2018-08-15 14:48:21 UTC
Created attachment 779803 [details]
Xorg.log output
Comment 13 Robert Mahar 2018-08-15 14:52:10 UTC
Comment on attachment 779803 [details]
Xorg.log output

( Just realized this Xorg.log does not show crash, it does show the driver init )
Comment 14 Takashi Iwai 2018-08-16 07:01:08 UTC
According to the upstream bugzilla, this sounds like an issue with xf86-video-ati.
  https://bugs.freedesktop.org/show_bug.cgi?id=107528#c12
  https://bugs.freedesktop.org/show_bug.cgi?id=105381#c22

Stefan, Michal, could you guys take care of it?
Comment 15 Stefan Dirsch 2018-08-16 14:39:24 UTC
Fixed in X11:XOrg and submitrequested for factory.

-------------------------------------------------------------------
Thu Aug 16 14:19:06 UTC 2018 - sndirsch@suse.com

- Update to release 18.0.99 (git describe: 18.0.1-44-g740f0850)
  * supposed to provide a fix for boo#1100759, fdo#107528, fdo#105381

https://build.opensuse.org/request/show/629601

Please let us know, if this update really fixes the issue. Thanks!
Comment 16 Swamp Workflow Management 2018-08-16 15:20:06 UTC
This is an autogenerated message for OBS integration:
This bug (1100759) was mentioned in
https://build.opensuse.org/request/show/629603 Factory / xf86-video-ati
Comment 19 Stefan Dirsch 2018-09-05 12:55:43 UTC
Do you have an update meanwhile? BTW, the package update just has been accepted for factory/Tumbleweed.
Comment 20 Andrey Karepin 2018-09-05 13:15:00 UTC
*** Bug 1106635 has been marked as a duplicate of this bug. ***
Comment 22 Matej Cepl 2018-09-13 10:32:30 UTC
OK, it turns out the hardware was probably faulty.