Bug 1100704 - OOO_FORCE_DESKTOP ignored by LibreOffice 6.1
OOO_FORCE_DESKTOP ignored by LibreOffice 6.1
Status: RESOLVED UPSTREAM
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: LibreOffice
Current
x86-64 SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: Tomáš Chvátal
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-10 08:29 UTC by Kriton Kyrimis
Modified: 2018-07-17 08:26 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kriton Kyrimis 2018-07-10 08:29:22 UTC
The new 6.1 version of LibreOffice ignores the environment variable OOO_FORCE_DESKTOP, always coming up with a gtk3 interface.

I tried using "kde", "kde4", "kde5" and "none" as values for this variable, and I always get a gtk3 interface. This does not happen with the official binaries from the Document Foundation.

The strange thing is that I keep getting a gtk interface, even if I uninstall the  libreoffice-gtk3, libreoffice-gnome, and libreoffice-gtk2 packages, which suggests that gtk may be hardwired into the Tumbleweed build. This sounds strange, as LibreOffice 6.1 is supposed to have improved KDE 5 support!

I am using libreoffice 6.1.0.0.beta2-1.1 under OpenSUSE Tumbleweed 20180707. I am using the plasma desktop, and the libreoffice-qt5 package *is* installed.
Comment 1 Tomáš Chvátal 2018-07-16 08:35:54 UTC
Please go to about dialog in HELP->About Libreoffice and check the values there.

For me on gnome it reports stuff like:

Verze: 6.1.0.1
ID sestavení: 10(Build:1)
Vlákna CPU: 8; OS: Linux 4.17; Vykreslování UI: výchozí; VCL: gtk3; 
Národní prostředí: cs-CZ (cs_CZ.UTF-8); Calc: group threaded

The VCL statement is what you look for, but without the gtk3 and gtk2 package it can't sue the VCLs...
Comment 2 Kriton Kyrimis 2018-07-16 08:53:08 UTC
Here's what the "about" dialog shows:

Version: 6.1.0.0.beta2+
Build ID: 10(Build:0)
CPU threads: 2; OS: Linux 4.17; UI render: default; VCL: gtk3_kde5; 
Locale: el-GR (en_US.UTF-8); Calc: CL

Note that I do have the gtk2 and gtk3 packages installed. What I don't want is to have them used instead of the qt5 package, which is also installed. However, the tumbleweed build of LO wants to use gtk so much, that even if I remove these packages, as a test, it still uses gtk, instead of a common denominator X11 UI. (I could get that using OOO_FORCE_DESKTOP=none in 6.0.)

For completeness, here is the list of LibreOffice packages that I currently have installed:

libreoffice-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-base-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-branding-upstream-6.1.0.0.beta2-1.2.noarch.rpm
libreoffice-calc-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-calc-extensions-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-draw-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-filters-optional-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-gnome-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-gtk2-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-gtk3-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-icon-themes-6.1.0.0.beta2-1.2.noarch.rpm
libreoffice-impress-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-l10n-el-6.1.0.0.beta2-1.2.noarch.rpm
libreoffice-l10n-en-6.1.0.0.beta2-1.2.noarch.rpm
libreoffice-mailmerge-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-math-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-pyuno-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-qt5-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-share-linker-1-4.4.noarch.rpm
libreoffice-writer-6.1.0.0.beta2-1.2.x86_64.rpm
libreoffice-writer-extensions-6.1.0.0.beta2-1.2.x86_64.rpm
Comment 3 Tomáš Chvátal 2018-07-16 09:00:37 UTC
It is correct.

as it says the VCL is gtk3_kde5 which is the required interface on plasma5 enviroment as per what was asked by kde team.

If that looks ugly then it is problem of the KDE part.
Comment 4 Tomáš Chvátal 2018-07-16 09:02:30 UTC
OOO_FORCE_DESKTOP=none just mean autodetect.

if you want to force the generic X11 use ie:

SAL_USE_VLCPLUGIN=gen lowriter
Comment 5 Kriton Kyrimis 2018-07-16 09:06:04 UTC
For comparison, here's what the "about" dialog says, if I run the LibreOffice binaries provided by the Document Foundation:

Version: 6.1.0.1
Build ID: 378e26bd4f22a135cef5fa17afd5d4171d8da21a
CPU threads: 2; OS: Linux 4.17; UI render: default; VCL: kde4; 
Locale: el-GR (en_US.UTF-8); Calc: CL

It uses a different VCL.
Comment 6 Tomáš Chvátal 2018-07-16 09:09:58 UTC
(In reply to Kriton Kyrimis from comment #5)
> For comparison, here's what the "about" dialog says, if I run the
> LibreOffice binaries provided by the Document Foundation:
> 
> Version: 6.1.0.1
> Build ID: 378e26bd4f22a135cef5fa17afd5d4171d8da21a
> CPU threads: 2; OS: Linux 4.17; UI render: default; VCL: kde4; 
> Locale: el-GR (en_US.UTF-8); Calc: CL
> 
> It uses a different VCL.

Yep that is kde4 qt4 based integration which is not supported.
Comment 7 Kriton Kyrimis 2018-07-16 10:32:05 UTC
> SAL_USE_VLCPLUGIN=gen lowriter

I still get the gtk3_kde5 UI, both with SAL_USE_VLCPLUGIN=gen and OOO_FORCE_DESKTOP=gen.

Looking a bit further into it, it seems that even the official binaries ignore OOO_FORCE_DESKTOP, though in a slightly different manner, possibly because they are slightly newer (version 6.1.0.1, instead of 6.1.0.0 beta): I always get the kde4 interface, unless I remove the KDE integration package. If I do remove it, I then always get the gtk2 interface, unless I remove the gnome integration package, in which case I get the generic X11 interface. I'll report this upstream.
Comment 8 Kriton Kyrimis 2018-07-16 10:36:51 UTC
> If that looks ugly then it is problem of the KDE part.

Or lack thereof. Even the name gtk3_kde5 suggests that gtk3 is being used. However, if that is how LibreOffice chooses to implement a KDE UI, there's not much that can be done.
Comment 9 Kriton Kyrimis 2018-07-16 10:45:38 UTC
> Yep that is kde4 qt4 based integration which is not supported.

Um, why?

Given that the official binaries run fine, the required libraries are available. I can understand why they would not be supported, if these libraries were provided by third parties, but from what I can tell by looking, e.g., at libqt4 and libkde4, they are provided by the main OpenSUSE Tumbleweed repository.
Comment 10 Tomáš Chvátal 2018-07-17 08:26:54 UTC
libqt4 and kdelibs4 are both being obsoleted and we need to switch to the current plasma5 UI.

I recommend opening bugs for KDE UI or upstream on bugs.documentfoundation.org to get changes in, we just repackage what is provided.