Bug 1100516 - qemu process kills itself with SIGABRT
qemu process kills itself with SIGABRT
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Xen
Current
x86-64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Bruce Rogers
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-08 22:47 UTC by Adam Mizerski
Modified: 2018-07-18 21:23 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Mizerski 2018-07-08 22:47:27 UTC
Steps to reproduce:
1. install openSUSE Tumbleweed in a VM under XEN

At random the VM crashes:

#0  0x00007f8e7b1d208b in raise () from /lib64/libc.so.6
#1  0x00007f8e7b1bb4e9 in abort () from /lib64/libc.so.6
#2  0x00007f8e7b1bb3c1 in __assert_fail_base.cold.0 () from /lib64/libc.so.6
#3  0x00007f8e7b1ca6f2 in __assert_fail () from /lib64/libc.so.6
#4  0x000055f50a300e9c in blk_get_attached_dev_id (blk=<optimized out>) at block/block-backend.c:898
#5  0x000055f50a305872 in bdrv_query_info (errp=0x7ffc19a6be30, p_info=0x55f50c2d6138, blk=0x55f50c9945a0) at block/qapi.c:359
#6  qmp_query_block (errp=errp@entry=0x7ffc19a6be90) at block/qapi.c:559
#7  0x000055f50a0cd667 in qmp_marshal_query_block (args=0x55f50c871ae0, ret=0x7ffc19a6bf00, errp=0x7ffc19a6bef8) at qapi/qapi-commands-block-core.c:97
#8  0x000055f50a3850f7 in do_qmp_dispatch (errp=0x7ffc19a6bef0, request=0x7ffc19a6bef0, cmds=<optimized out>) at qapi/qmp-dispatch.c:111
#9  qmp_dispatch (cmds=<optimized out>, request=request@entry=0x55f50b94c2d0) at qapi/qmp-dispatch.c:160
#10 0x000055f509fbdd8e in monitor_qmp_dispatch_one (req_obj=req_obj@entry=0x55f50b94ea60) at /usr/src/debug/qemu-2.12.0-2.4.x86_64/monitor.c:4089
#11 0x000055f509fbe0c8 in monitor_qmp_bh_dispatcher (data=<optimized out>) at /usr/src/debug/qemu-2.12.0-2.4.x86_64/monitor.c:4147
#12 0x000055f50a38f5ee in aio_bh_call (bh=0x55f50b92ab60) at util/async.c:118
#13 aio_bh_poll (ctx=ctx@entry=0x55f50b91b7c0) at util/async.c:118
#14 0x000055f50a392850 in aio_dispatch (ctx=0x55f50b91b7c0) at util/aio-posix.c:436
#15 0x000055f50a38f4ce in aio_ctx_dispatch (source=<optimized out>, callback=<optimized out>, user_data=<optimized out>) at util/async.c:261
#16 0x00007f8e8083e0be in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#17 0x000055f50a391b58 in glib_pollfds_poll () at util/main-loop.c:215
#18 os_host_main_loop_wait (timeout=<optimized out>) at util/main-loop.c:263
#19 main_loop_wait (nonblocking=<optimized out>) at util/main-loop.c:522
#20 0x000055f509f733ce in main_loop () at vl.c:1944
#21 main (argc=<optimized out>, argv=<optimized out>, envp=<optimized out>) at vl.c:4746
Comment 1 Adam Mizerski 2018-07-12 20:23:14 UTC
For the record:
xen version: 4.10.1_08-1.1
qemu version: 2.12.0-2.4
Comment 2 Bruce Rogers 2018-07-16 16:47:21 UTC
I've not dug into exactly what's going wrong here, but any day now a new qemu will hit the Tumbleweed repo with changes where there is no longer this assert you're hitting in blk_get_attached_dev_id. At that point this should no longer be an issue. Can you hold on til then?
Comment 3 Adam Mizerski 2018-07-16 17:17:20 UTC
Sure. What version number will it be?
Comment 4 Bruce Rogers 2018-07-16 17:41:49 UTC
(In reply to Adam Mizerski from comment #3)
> Sure. What version number will it be?

qemu-2.12.0-3.1 is what's in factory right now.
Comment 5 Bruce Rogers 2018-07-18 12:57:00 UTC
Updated qemu package is now available for Tumbleweed. Could you check if you still have issues with the latest qemu?
Comment 6 Adam Mizerski 2018-07-18 20:30:42 UTC
It's running for a while and not crashing. Seems to be fixed :)
Comment 7 Adam Mizerski 2018-07-18 21:23:25 UTC
changing status to resolved