Bug 1100497 - wxwidgets: self compiled binary fails to run with version missmatch
wxwidgets: self compiled binary fails to run with version missmatch
Status: RESOLVED FIXED
: 1101374 1101948 1101960 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
Other Other
: P5 - None : Normal with 4 votes (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-07 14:08 UTC by Peter Sütterlin
Modified: 2018-07-26 02:50 UTC (History)
8 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Sütterlin 2018-07-07 14:08:39 UTC
I'm compiling a program (phd2 from the openguiding project) that uses wxWidgets.
The program builds fine, but when I try to run it I get

woodstock:mybuild% ./phd2 
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1012,STL containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1013,STL containers,compatible with 2.8).
Aborted (core dumped)

Indeed, a grep reveals
woodstock:mybuild% strings phd2 |grep "C++ ABI"
3.0 (wchar_t,compiler with C++ ABI 1013,STL containers,compatible with 2.8)
woodstock:mybuild% strings /usr/lib64/libwx_baseu-3.0.so |grep "C++ ABI"
3.0 (wchar_t,compiler with C++ ABI 1012,STL containers,compatible with 2.8)

All installed wxwidget packages are same(current) version:

S  | Name                           | Type    | Version     | Arch   | Repository         
---+--------------------------------+---------+-------------+--------+--------------------
i  | libwx_baseu-suse3_0_4          | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_baseu_net-suse3_0_4      | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_baseu_xml-suse3_0_4      | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_gtk2u_adv-suse3_0_4      | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_gtk2u_aui-suse3_0_4      | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_gtk2u_core-suse3_0_4     | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_gtk2u_gl-suse3_0_4       | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_gtk2u_html-suse3_0_4     | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_gtk2u_media-suse3_0_4    | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_gtk2u_propgrid-suse3_0_4 | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_gtk2u_qa-suse3_0_4       | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_gtk2u_ribbon-suse3_0_4   | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_gtk2u_richtext-suse3_0_4 | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_gtk2u_stc-suse3_0_4      | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i  | libwx_gtk2u_xrc-suse3_0_4      | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
i+ | wxWidgets-3_0-devel            | package | 3.0.4-1.2   | x86_64 | openSUSE-Tumbleweed
Comment 1 Peter Sütterlin 2018-07-09 09:53:32 UTC
Likely a 'duplicate' of this one:
https://bugzilla.suse.com/show_bug.cgi?id=953017
and requires someone to trigger a wxwidgets rebuild for TW?
Comment 2 Noah Davis 2018-07-13 20:30:05 UTC
I have experience the same exact issue, but with rsu-client (https://github.com/rsu-client/rsu-client).
Comment 3 Karl Cheng 2018-07-17 01:31:39 UTC
Audacity is also affected by this issue. Testing out the recent 3.0.4-2.1 in Factory, it's still problematic: it's now showing up ABI 1002 vs ABI 1013.

qantas94heavy@linux-abcd:~> audacity
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1002,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8).
Aborted (core dumped)
Comment 4 Konstantin Voinov 2018-07-17 13:01:30 UTC
That's sad bug, at least with Audacity for me.
Comment 5 Jan Engelhardt 2018-07-17 15:04:20 UTC
Should be fixed since (date/version):

2018-07-13 17:28:28   f7cf490129e2dc0d38ae80008cdcab6a    3.0.4-2.1        26       1018
Comment 6 Karl Cheng 2018-07-18 13:37:06 UTC
With TW 20180714 and 3.0.4-2.1 I can still reproduce this issue with audacity. Does audacity also need a rebuild?
Comment 7 Wolfgang Bauer 2018-07-19 17:40:21 UTC
*** Bug 1101374 has been marked as a duplicate of this bug. ***
Comment 8 Peter Sütterlin 2018-07-19 18:42:02 UTC
I can confirm report from Karl Cheng in Comment #3:
I just upgraded to TW 20180714 which has the new wxwidgets build 2.1 in.
But now my selfcompiled programs die again with the compiler ABI missmatch, now 1002 vs 1013, so even larger than before.

I had fetched the source rpm of wxwidgets (still of the previous version, 1.2) and compiled the packages myself.  With that it worked, without recompile of my own program.

What compiler was used to build the packages?  I'm using the TW default, gcc 8.1.  Or is this not the problem?
Comment 9 Jan Engelhardt 2018-07-19 19:29:03 UTC
1002 is the only acceptable value henceforth, as defined by upstream. Anything that does not have it will need a rebuild.
Comment 10 Peter Sütterlin 2018-07-19 19:45:36 UTC
Ah, my bad.  Wasn't clear to me from the description.
Yes, I rebuilt my program, and it runs now w/o error :)
Comment 11 Wolfgang Bauer 2018-07-19 20:49:48 UTC
*** Bug 1101948 has been marked as a duplicate of this bug. ***
Comment 12 S. B. 2018-07-19 21:38:32 UTC
This is still happening with Tumbleweed 20180714:

> Fatal Error: Mismatch between the program and library build versions detected.
> The library used 3.0 (wchar_t,compiler with C++ ABI 1002,wx 
> containers,compatible with 2.8), and your program used 3.0 
> (wchar_t,compiler with C++ ABI 1013,wx containers,compatible
> with 2.8). 
> “audacity” terminated by signal SIGABRT (Abort)
Comment 13 S. B. 2018-07-19 21:39:20 UTC
Oops, sorry, I just realized this is a bug for wxwidgets.
Comment 14 Wolfgang Bauer 2018-07-19 21:59:06 UTC
*** Bug 1101960 has been marked as a duplicate of this bug. ***
Comment 15 Geoffrey Fagan 2018-07-26 02:50:12 UTC
Works for me now as of 20180723 Tumbleweed update. -GEF