Bug 1100496 - neovim should depend on specific version of libtermkey1
neovim should depend on specific version of libtermkey1
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Martin Liška
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-07 12:11 UTC by John Ford
Modified: 2019-02-12 11:09 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Ford 2018-07-07 12:11:34 UTC
After upgrading neovim to 0.3.0-1.1 it gave me the following error:

nvim: symbol lookup error: nvim: undefined symbol: termkey_hook_terminfo_getstr

It seems like neovim requires a new version of libtermkey1, but does not specify this, so that package is not automatically updated when neovim is updated.
Comment 1 Martin Liška 2018-07-16 14:23:36 UTC
Tomas current spec file contains:

BuildRequires:  pkgconfig(termkey) >= 0.20

Is it also needed to have:

Requires:  pkgconfig(termkey) >= 0.20

or not?
Comment 2 Martin Liška 2018-07-16 14:39:08 UTC
I have fix for that.
Comment 3 Swamp Workflow Management 2018-07-16 15:10:05 UTC
This is an autogenerated message for OBS integration:
This bug (1100496) was mentioned in
https://build.opensuse.org/request/show/623146 Factory / neovim
Comment 4 Martin Liška 2018-10-03 13:26:27 UTC
Should be fixed now.
Comment 5 Swamp Workflow Management 2018-12-08 18:10:18 UTC
This is an autogenerated message for OBS integration:
This bug (1100496) was mentioned in
https://build.opensuse.org/request/show/656415 15.0 / libtermkey+lua51-bit32+neovim+python-neovim
Comment 6 Swamp Workflow Management 2019-02-08 11:11:15 UTC
openSUSE-RU-2019:0151-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1094627,1098800,1100496
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    libtermkey-0.20-lp150.2.3.1, lua51-bit32-5.3.0-lp150.2.1, neovim-0.3.1-lp150.2.3.1, python-neovim-0.3.1-lp150.2.3.1
Comment 7 Swamp Workflow Management 2019-02-12 11:09:05 UTC
openSUSE-RU-2019:0157-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1094627,1098800,1100496
CVE References: 
Sources used:
openSUSE Backports SLE-15 (src):    libtermkey-0.20-bp150.3.3.1, lua51-bit32-5.3.0-bp150.2.1, neovim-0.3.1-bp150.2.3.1, python-neovim-0.3.1-bp150.3.3.1