Bug 1100493 - Lots of different font sizes after tumbleweed update
Lots of different font sizes after tumbleweed update
Status: RESOLVED DUPLICATE of bug 1100495
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-07 09:09 UTC by Markus Zimmermann
Modified: 2018-07-12 14:23 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Screenshot of Yast and some KDE applications context menus and such. (1.84 MB, image/png)
2018-07-07 09:09 UTC, Markus Zimmermann
Details
Output for "QT_LOGGING_RULES=*.debug=true kdialog --asdf" (3.45 KB, text/plain)
2018-07-12 14:12 UTC, Markus Zimmermann
Details
Output for "qdbus-qt5 org.kde.KWin /KWin org.kde.KWin.supportInformation" (4.85 KB, text/plain)
2018-07-12 14:12 UTC, Markus Zimmermann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Zimmermann 2018-07-07 09:09:41 UTC
Created attachment 776415 [details]
Screenshot of Yast and some KDE applications context menus and such.

I am using a 4k display (Samsung U28E850 with 3840x2160) on Tumbleweed 20180704

After the latest update of Tumbleweed to 20180704 I have lots of different font sizes. Especially the font size for the context menu of the task manager and the window title bar cannot be changed anymore by KDE's font configuration. I guess this is related to the QT/DPI change that was mentioned in the mailing list.
Comment 1 Fabian Vogt 2018-07-07 15:08:43 UTC
(In reply to Markus Zimmermann from comment #0)
> Created attachment 776415 [details]
> Screenshot of Yast and some KDE applications context menus and such.
> 
> I am using a 4k display (Samsung U28E850 with 3840x2160) on Tumbleweed
> 20180704
> 
> After the latest update of Tumbleweed to 20180704 I have lots of different
> font sizes. Especially the font size for the context menu of the task
> manager and the window title bar cannot be changed anymore by KDE's font
> configuration. I guess this is related to the QT/DPI change that was
> mentioned in the mailing list.

Does it work if you run "kwin_x11 --replace" and "kquitapp5 plasmashell; plasmashell"?

If not, does it work if you override the font DPI to 96 and logout/login again?


Please attach the output of

QT_LOGGING_RULES=*.debug=true kdialog --asdf

and

qdbus-qt5 org.kde.KWin /KWin org.kde.KWin.supportInformation
Comment 2 Markus Zimmermann 2018-07-12 14:11:22 UTC
(In reply to Fabian Vogt from comment #1)
> Does it work if you run "kwin_x11 --replace" and "kquitapp5 plasmashell;
> plasmashell"?

"kwin_x11 --replace" brings the font-size of the window titlebar up to the correct size. And restarting Plasma works for bringing back the correct sizes of the context menu and the context menu position. Thank you for the workaround!

> Please attach the output of
> 
> QT_LOGGING_RULES=*.debug=true kdialog --asdf
> 
> and
> 
> qdbus-qt5 org.kde.KWin /KWin org.kde.KWin.supportInformation

Will do.

Do you have any input on how to get the correct size for Yast?
Comment 3 Markus Zimmermann 2018-07-12 14:12:00 UTC
Created attachment 776813 [details]
Output for "QT_LOGGING_RULES=*.debug=true kdialog --asdf"
Comment 4 Markus Zimmermann 2018-07-12 14:12:24 UTC
Created attachment 776814 [details]
Output for "qdbus-qt5 org.kde.KWin /KWin org.kde.KWin.supportInformation"
Comment 5 Fabian Vogt 2018-07-12 14:23:38 UTC
(In reply to Markus Zimmermann from comment #2)
> (In reply to Fabian Vogt from comment #1)
> > Does it work if you run "kwin_x11 --replace" and "kquitapp5 plasmashell;
> > plasmashell"?
> 
> "kwin_x11 --replace" brings the font-size of the window titlebar up to the
> correct size. And restarting Plasma works for bringing back the correct
> sizes of the context menu and the context menu position. Thank you for the
> workaround!

Ok, so it's a duplicate of bug 1100495.

> > Please attach the output of
> > 
> > QT_LOGGING_RULES=*.debug=true kdialog --asdf
> > 
> > and
> > 
> > qdbus-qt5 org.kde.KWin /KWin org.kde.KWin.supportInformation
> 
> Will do.
> 
> Do you have any input on how to get the correct size for Yast?

Judging by the screenshot YaST has the correct size already.

You can always revert to the old behaviour (with small fonts) by setting "Force fonts DPI" in the fonts KCM to 96.

*** This bug has been marked as a duplicate of bug 1100495 ***