Bug 1099804 - Gnucash is unable to retrieve and open guide files in openSUSE LEAP 15.0
Gnucash is unable to retrieve and open guide files in openSUSE LEAP 15.0
Status: RESOLVED FIXED
: 1014929 (view as bug list)
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: GNOME
Leap 15.0
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-02 08:41 UTC by Michele Di Pede
Modified: 2022-04-01 14:15 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michele Di Pede 2018-07-02 08:41:28 UTC
I am using openSUSE Leap 15.0 with KDE.
Gnucash is not able to locate and open the guide file despite the gnucash-docs package is correctly installed.
I tried to dig a bit deeper with this invocation:

gnucash --debug --extra --log gnc.gui=debug

This is the relevant part of the trace file:
[...]
* 10:00:08 DEBUG <gnc.gui> [enter ../gnucash/gnome-utils/gnc-file.c:gnc_post_file_open()] filename 
* 10:00:14 DEBUG <gnc.gui>     [gnc_gnome_help] Attempting to opening help uri ghelp:gnucash-guide
* 10:00:16  CRIT <gnc.gui>     [gnc_gnome_help()] La posizione specificata non รจ supportata
[...]

Last trace is the italian translation for "The specified position is not supported".

In my system the gnucash configuration file /.gnucash/config.auto is not present despite it is mentioned in gnucash man help file.
Comment 1 Ferdinand Thiessen 2018-12-23 19:34:20 UTC
Same on Tumbleweed.
Solution: Install the gnome help browser (/usr/bin/gnome-help) (for openSUSE: yelp).
Comment 2 Swamp Workflow Management 2018-12-26 13:40:06 UTC
This is an autogenerated message for OBS integration:
This bug (1099804) was mentioned in
https://build.opensuse.org/request/show/661487 15.0+42.3+Backports:SLE-15 / gnucash-docs
Comment 3 Ferdinand Thiessen 2019-01-05 00:50:14 UTC
Request #661487 got accepted.
Comment 4 Swamp Workflow Management 2019-01-12 02:20:56 UTC
openSUSE-RU-2019:0018-1: An update that has one recommended fix can now be installed.

Category: recommended (low)
Bug References: 1099804
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    gnucash-docs-2.6.16-8.3.1
openSUSE Leap 15.0 (src):    gnucash-docs-3.0-lp150.2.3.1
openSUSE Backports SLE-15 (src):    gnucash-docs-3.0-bp150.3.3.1
Comment 5 Atri Bhattacharya 2022-04-01 14:15:02 UTC
*** Bug 1014929 has been marked as a duplicate of this bug. ***