Bug 1098894 - Edit / Delete addresses in Kaddressbook is impossible
Edit / Delete addresses in Kaddressbook is impossible
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Applications
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-06-22 21:55 UTC by Berndt Tobias
Modified: 2018-11-27 21:48 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Berndt Tobias 2018-06-22 21:55:37 UTC
How to reproduce?

- Edit one of your contacts or create a new contact in KAddressbook or Kontact.
- In the Edit-dialog, select the second tab to add/edit/delete the contact's addresses like street, zip-code, country etc. 
- In the right half of the Edit-dialog then some sort of listview should show already existing addresses of this contact, so you may modify or delete one of these addresses.

Despite already existing addresses, the list always remains blank, even if you add a new one nothing changes. So modifying or deleting an existing address is impossible as it cannot be selected. Anyway, a newly added address seems to be stored correctly, as it shows up in the contact overview in KAddressbook's main window (and is synced via webdav).

I do not use KAddressbook very often for editing or adding addresses, so I can't determine when this issue occured first.

I'm using
KAddressbook / Kontact 18.04.2.1-1 from repo
KDE Framework 5.46
Tumbleweed 20180620
Comment 1 Berndt Tobias 2018-08-02 21:49:01 UTC
I ran zypper dup on a second machine today which had not received repo updates for several month. 
This brought KAddressbook from 17.xx to 18.04 and introduced the same issue: Editing or deleting of address data is impossible as the list of addresses remains blank despite of existing data in the edit dialog window.

Any suggestions anyone?
Comment 2 Berndt Tobias 2018-11-27 21:48:04 UTC
Has been solved in some repo update. Thanks.