Bug 1098431 - Qt based applications do not work over SSH X forwarded connection
Qt based applications do not work over SSH X forwarded connection
Status: RESOLVED DUPLICATE of bug 1097227
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-06-20 13:59 UTC by Libor Pechacek
Modified: 2018-06-20 14:02 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
frozen YaST2 Qt interface (78.83 KB, image/jpeg)
2018-06-20 13:59 UTC, Libor Pechacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Libor Pechacek 2018-06-20 13:59:35 UTC
Created attachment 774683 [details]
frozen YaST2 Qt interface

After one of the recent TW updates (cannot tell the exact version), a few Qt based applications stopped working over SSH X forwarding. Tested with Qt Creator, a custom built Qt application (OO Mapper) and YaST2. At the same time some other X based applications work fine - xterm, xmessage, git gui, gitk.

Example replication procedure (from the attached picture):
lpechacek@fm:~> ssh -X -l user germ146.suse.cz
Last login: Wed Jun 20 15:45:26 2018 from 10.100.13.15
Have a lot of fun...
user@germ146:~> /usr/sbin/yast2 --qt
 # ... window appears but remains black
 # strace shows events are delivered to the application

With TW 20180530 these Qt applications worked fine.

According to https://lists.opensuse.org/opensuse-factory/2018-06/msg00076.html KDE apps are affected too and the issue first appeared with TW 20180606.
Comment 1 Wolfgang Bauer 2018-06-20 14:02:44 UTC
A fix has been submitted a week ago already, but is still stuck in staging...
https://build.opensuse.org/request/show/616864

*** This bug has been marked as a duplicate of bug 1097227 ***