Bug 1098074 - Keyboard does not work under Linux kernel 4.17.1
Keyboard does not work under Linux kernel 4.17.1
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-06-18 15:40 UTC by Noah Davis
Modified: 2018-06-20 20:19 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
hwinfo - kernel 4.16.12 (1.45 MB, text/plain)
2018-06-18 16:22 UTC, Noah Davis
Details
hwinfo - kernel 4.17.1 (1.32 MB, text/plain)
2018-06-18 16:22 UTC, Noah Davis
Details
dmesg - kernel 4.16.12 (65.90 KB, text/plain)
2018-06-18 16:23 UTC, Noah Davis
Details
dmesg - kernel 4.17.1 (63.72 KB, text/plain)
2018-06-18 16:23 UTC, Noah Davis
Details
dmesg - kernel 4.18.0-rc1 (64.16 KB, text/plain)
2018-06-19 21:53 UTC, Noah Davis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Noah Davis 2018-06-18 15:40:45 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build Identifier: 

After booting with Linux kernel version 4.17.1, my keyboard does not work. No input, no backlight, it just seems to be shut off.

Reproducible: Always

Steps to Reproduce:
1. Boot with kernel 4.17.1
2. Try to do anything with the keyboard (log in, change keyboard backlight brightness, etc)
Actual Results:  
Keyboard does not work at all.

Expected Results:  
Keyboard should be on and functional.

The power button, which is not part of the keyboard, still works.
They keyboard works again if I switch to the previous kernel, version 4.16.12.
I'm using an ASUS K501UW laptop.
Comment 1 Takashi Iwai 2018-06-18 15:55:43 UTC
I assume you're referring to the laptop keyboard?  Can you check whether any external USB keyboard works or not?

If the USB keyboard works, it's likely an issue with asus_hid or such.

In anyway, please boot the old good kernel, run hwinfo, and attach the output to Bugzilla.

If the USB keyboard works with the newer kernel, it'd be great if you can get hwinfo output with the new kernel.  Also give the full output of dmesg after boot, too.
Comment 2 Noah Davis 2018-06-18 16:22:08 UTC
Created attachment 774371 [details]
hwinfo - kernel 4.16.12
Comment 3 Noah Davis 2018-06-18 16:22:42 UTC
Created attachment 774373 [details]
hwinfo - kernel 4.17.1
Comment 4 Noah Davis 2018-06-18 16:23:14 UTC
Created attachment 774375 [details]
dmesg - kernel 4.16.12
Comment 5 Noah Davis 2018-06-18 16:23:48 UTC
Created attachment 774376 [details]
dmesg - kernel 4.17.1
Comment 6 Noah Davis 2018-06-18 16:25:16 UTC
(In reply to Takashi Iwai from comment #1)
> I assume you're referring to the laptop keyboard?  Can you check whether any
> external USB keyboard works or not?
> 
> If the USB keyboard works, it's likely an issue with asus_hid or such.
> 
> In anyway, please boot the old good kernel, run hwinfo, and attach the
> output to Bugzilla.
> 
> If the USB keyboard works with the newer kernel, it'd be great if you can
> get hwinfo output with the new kernel.  Also give the full output of dmesg
> after boot, too.

Yes, it is the laptop keyboard that does not work. My external HP KU-1060 USB keyboard does work.
Comment 7 Takashi Iwai 2018-06-19 05:44:31 UTC
Thanks!

Comparing the logs shows that i8042 port detection failed.

On 4.16:
[    2.285161] i8042: PNP: PS/2 Controller [PNP030b:PS2K] at 0x60,0x64 irq 1
[    2.285193] i8042: PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp
[    2.286390] serio: i8042 KBD port at 0x60,0x64 irq 1
[    2.286484] mousedev: PS/2 mouse device common for all mice
....
[    2.297060] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input0

Meanwhile on 4.17:
[    2.215855] i8042: PNP: No PS/2 controller found.
[    2.215951] mousedev: PS/2 mouse device common for all mice

There have been significant amount of code refactoring regarding ps2 in 4.17, and the regression might come from that.

Could you try to add a boot option "libps2.dyndbg=+pf" and get the kernel messages again?
Comment 8 Takashi Iwai 2018-06-19 05:55:06 UTC
(In reply to Takashi Iwai from comment #7)
> There have been significant amount of code refactoring regarding ps2 in
> 4.17, and the regression might come from that.

Scratch this; it's not about the i8042 detection but ACPI PnP seems broken.
On 4.17, there is no PNP030b for the keyboard.  Also lots of other PnP entries are missing.

On 4.16:
[    0.390244] pnp: PnP ACPI: found 9 devices

On 4.17:
[    0.263266] pnp: PnP ACPI: found 0 devices
Comment 9 Takashi Iwai 2018-06-19 06:11:27 UTC
I'm going to report this to upstream now.  You'll be on Cc.
Comment 10 Takashi Iwai 2018-06-19 20:09:11 UTC
Could you check OBS Kernel:HEAD repo to see whether the problem is gone with 4.18-rc1?
  http://download.opensuse.org/repositories/Kernel:/HEAD/standard/

BTW, while testing kernel packages, it's safer to increase the number of parallel installed kernels by editing /etc/zypper/zypp.conf.  Add more in multiversion.kernels definition in the file.
Comment 11 Mark Draheim 2018-06-19 20:41:40 UTC
affects my two Asus Laptops: UX303UB and N705UQ. Having no keyboard at boot is a bit annoying with luks encrypted root ;-)

Alright, will try 4.18 but I do hope upstream fixes 4.17, too. I mean Asus Laptops are kind of common out there.
Comment 12 Mark Draheim 2018-06-19 21:07:56 UTC
Kernel:HEAD kernel-default-4.18.rc1-1.1.gfa9e020 works on my UX303UB. I can enter luks pw at boot. Will check N705UQ tomorrow.

Current TW kernel-default-4.17.1-1.5 does not work. The older kernel-default-4.16.12-3.5 works.
Comment 13 Noah Davis 2018-06-19 21:53:02 UTC
Created attachment 774570 [details]
dmesg - kernel 4.18.0-rc1

The problem is gone with kernel 4.18.0-rc1.
Comment 14 Takashi Iwai 2018-06-20 09:10:18 UTC
Thanks, it's at least a good news.

I'm building a test kernel with the backported fix Rafael suggested.
It's being built in OBS home:tiwai:4.17-acpica-fix repo.  It'll be finished in an hour or so.

Please give it a try later, and report back if it works or not.
Comment 15 Mark Draheim 2018-06-20 19:28:30 UTC
4.17.2-1.gfc39d10-default seems to work fine on my UX303UB. Keyboard works at luks pw prompt, keyboard backlight ist fine, looks good
Comment 16 Takashi Iwai 2018-06-20 20:19:43 UTC
Good to hear!

I pushed the fix to my stable user branch.  It'll be merged to TW later.
Until it's merged to TW, keep using the kernel in my OBs repo.  Thanks.