Bug 1098066 - package obs-service-download_files: installation error
package obs-service-download_files: installation error
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Frank Schreiner
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-06-18 15:02 UTC by Giacomo Comes
Modified: 2018-12-21 07:58 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giacomo Comes 2018-06-18 15:02:39 UTC
After I perform a standard installation that includes also the pattern:
  devel_osc_build
I found this error in /var/log/zypp/history:

# 2018-06-18 06:56:01 obs-service-download_files-0.6.0.git.1502884469.0993a01-1.2.noarch.rpm installed ok
# Additional rpm output:
# warning: user obsrun does not exist - using root
# warning: group obsrun does not exist - using root
# warning: user obsrun does not exist - using root
# warning: group obsrun does not exist - using root
# warning: user obsrun does not exist - using root
# warning: group obsrun does not exist - using root
# 
2018-06-18 06:56:01|install|obs-service-download_files|0.6.0.git.1502884469.0993a01-1.2|noarch||openSUSE-20180615-0|c9447e3e713d553cb36ba76d505174efab6b1ea3a09d2c7147d0820a60b3ad5b|

The problem is that obs-service-download_files is installed before shadow and at that time the binaries groupadd and useradd used in the preinstall scriptlet, are not available yet.

A possible fix is to add this line in obs-service-download_files.spec:

Requires(pre):  shadow
Comment 1 Stefan Hundhammer 2018-06-18 16:09:23 UTC
Package problem, not installer related -> reassigning to component owner


osc maintainer -e obs-service-download_files
Defined in project:  openSUSE:Tools
  bugowner of obs-service-download_files : 
   ro@suse.com

  maintainer of obs-service-download_files : 
   adrian@suse.com, coolo@suse.com, lrupp@suse.com, FSchreiner@suse.com, aplanas@suse.com, marco.strigl@suse.com, -