Bug 1098041 - bcm43xx-firmware incompatible with transactional-update
bcm43xx-firmware incompatible with transactional-update
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Network
Current
aarch64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Matthias Brugger
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-06-18 12:57 UTC by Fabian Vogt
Modified: 2020-07-27 11:19 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Vogt 2018-06-18 12:57:15 UTC
Kubic for RPi3 does not enable WiFi, as the used /usr/sbin/install-brcmfmac tries to write to a read-only file system.

I suggest to use bind mounts of those files instead of symlinks, would that work?

Or alternatively, link from /lib/firmware/brcm/...txt to /var/... inside the package and create the link inside /var/... in the script.
Comment 2 Matthias Brugger 2020-07-23 14:19:34 UTC
Should be fixed for tumbleweed with https://build.opensuse.org/request/show/822326 accepted.
Comment 3 Matthias Brugger 2020-07-27 11:19:38 UTC
symlinks aren't needed anymore.