Bug 1097425 - Fails to create LVM volume if lvm+RAID1
Fails to create LVM volume if lvm+RAID1
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: heming zhao
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-06-13 10:38 UTC by Max Lin
Modified: 2019-10-14 06:42 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Max Lin 2018-06-13 10:38:52 UTC
According to https://openqa.opensuse.org/tests/690462 , installer fails to create LVM volume, the warning message pop-up due to dup'ed PV, looks like it proposed a broken setup.

y2log: https://openqa.opensuse.org/tests/690462/file/start_install-y2logs.tar.bz2
Comment 1 Arvin Schnell 2018-06-13 12:41:21 UTC
This looks like a problem of LVM. Since the devices /dev/vda2, /dev/vdb2, /dev/vdc2
and /dev/vdd2 are used by /dev/md0 LVM should not scan them for PVs. I was able
to reproduce the issue without using YaST on the ISO used by openQA (20180680) but
not older onces (e.g. 20180606).
Comment 2 Gang He 2018-06-19 06:41:44 UTC
Hello Guys,

The problem is a known issue for our current lvm2 code (2.02.177), due to spec file split.
please see the similar bug https://bugzilla.suse.com/show_bug.cgi?id=1091863

We have found the root cause, but we need to work with the build team to solve this issue.


Thanks
Gang
Comment 3 Michael Hanscho 2018-06-24 08:16:59 UTC
I assume this bug also prevents my machine from booting at all. OpenSuSE is installed on a raid1 with lvm ontop. The machine does not boot:
"Cannot activate LVs in VG vghome while PVs appear on duplicate devices"
Comment 4 Michael Hanscho 2018-06-25 19:33:14 UTC
Are there any workarounds known for the boot process to activate the pvm - as I am not able to boot my machine running lvm ontop raid1?
in rdsosreport.txt I find:
"Cannot activate LVs in VG vghome while PVs appear on duplicate devices."
Comment 7 Gang He 2018-10-09 02:47:18 UTC
Hello Max, Arvin, Michael and Oliver,

The bug is " failed to create LVM volume on top of raid1", right?
When did you encounter this problem? what is the lvm2 version?


Thanks
Gang
Comment 8 Max Lin 2018-10-11 09:03:46 UTC
This is happened on openQA a while ago, can not see this issue on Tumbleweed nowadays.
Comment 9 Gang He 2019-05-27 06:22:36 UTC
Assign this bug to Heming to follow up.
Comment 10 heming zhao 2019-10-14 06:42:44 UTC
For comment #8, close this bug as WONTFIX.