Bug 1095725 - Borg mount command missing dependency python3-llfuse
Borg mount command missing dependency python3-llfuse
Status: RESOLVED FIXED
: 1109703 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Antonio Larrosa
E-mail List
:
Depends on:
Blocks: 1109703
  Show dependency treegraph
 
Reported: 2018-06-04 06:30 UTC by Andrew Colvin
Modified: 2018-10-24 10:16 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Colvin 2018-06-04 06:30:00 UTC
Tumbleweed 

The command borg (from package borgbackup) fails when you use the borg mount <archive> <mountpoint> and outputs:
borg mount not available: loading FUSE support failed [ImportError: No module named 'llfuse']

the llfuse python library is not available in the repo providing borg nor any of the defaults and has to be installed from the filesystems repo at 
 http://download.opensuse.org/repositories/filesystems/openSUSE_Tumbleweed/

installing the python3-llfuse package from this repository makes the borg mount command function without issue
Comment 1 Antonio Larrosa 2018-06-19 11:39:39 UTC
Thanks for noticing this, Andrew.

I prepared an updated python-llfuse package and submitted it to Factory in https://build.opensuse.org/request/show/617713, so it should be available in some days in the Tumbleweed repositories.
Comment 2 Andrew Colvin 2018-06-19 13:55:02 UTC
great I will change vendor when it appears and test it.  

Thanks for the fast response for a minor issue with a workaround
Comment 3 Martin Winter 2018-09-18 18:46:58 UTC
Same bug also applies to openSUSE Leap 15.0. Please make this package also available in the Leap 15.0 repositories.
Comment 4 Andreas Stieger 2018-09-25 16:29:19 UTC
*** Bug 1109703 has been marked as a duplicate of this bug. ***
Comment 5 Swamp Workflow Management 2018-09-25 18:00:07 UTC
This is an autogenerated message for OBS integration:
This bug (1095725) was mentioned in
https://build.opensuse.org/request/show/638255 15.0+Backports:SLE-15 / python-llfuse
Comment 6 Swamp Workflow Management 2018-09-27 09:40:06 UTC
This is an autogenerated message for OBS integration:
This bug (1095725) was mentioned in
https://build.opensuse.org/request/show/638712 15.0+Backports:SLE-15 / python-llfuse
Comment 7 Swamp Workflow Management 2018-09-29 19:10:49 UTC
openSUSE-OU-2018:2950-1: An update that has one optional fix can now be installed.

Category: optional (low)
Bug References: 1095725
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    python-llfuse-1.3.5-lp150.2.1
openSUSE Backports SLE-15 (src):    python-llfuse-1.3.5-bp150.2.1
Comment 8 Antonio Larrosa 2018-10-24 10:16:47 UTC
The package was released for Tumbleweed and Leap 15, so this can be closed now