Bug 1095011 - Pakagekit should download appstream data on packagekit refresh
Pakagekit should download appstream data on packagekit refresh
Status: RESOLVED DUPLICATE of bug 1009745
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-29 11:48 UTC by Sasi Olin
Modified: 2020-06-25 14:09 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Gnome Software without said command run (17.38 KB, image/png)
2018-05-29 11:48 UTC, Sasi Olin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sasi Olin 2018-05-29 11:48:05 UTC
Created attachment 771667 [details]
Gnome Software without said command run

Gnome Software shows no contents unless `ZYPP_PLUGIN_APPDATA_FORCE_COLLECT=1 zypper ref` is run beforehand. dnf solves that by downloading data on refresh of repos in PackageKit. Zypp backend should probably follow, as refresh of repos in PackageKit doesn't influence zypper's behavior, and is done in the background, which should be noninvasive to end user.
Comment 1 Dominique Leuenberger 2020-06-25 14:09:16 UTC
This has been handled as part of bug 1009745

*** This bug has been marked as a duplicate of bug 1009745 ***