Bug 1094668 - Firefox start failure ppc64le in TW
Firefox start failure ppc64le in TW
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Firefox
Current
PowerPC Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
https://openqa.opensuse.org/tests/682...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-25 10:47 UTC by Michel Normand
Modified: 2020-01-27 15:03 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Normand 2018-05-25 10:47:11 UTC
Firefox start failure ppc64le in TW

the journalctl is reporting;
===
May 25 06:15:07 susetest kernel: firefox[15803]: unhandled signal 11 at 0000000000000000 nip 00000001260adfb8 lr 00000001260aef8c code 1
May 25 06:15:07 susetest systemd[1]: Started Process Core Dump (PID 15810/UID 0).
May 25 06:15:07 susetest kernel: firefox[15809]: unhandled signal 11 at 0000000000000008 nip 00000001260ade18 lr 00000001260aef8c code 1
May 25 06:15:07 susetest systemd[1]: Started Process Core Dump (PID 15812/UID 0).
May 25 06:15:07 susetest systemd-coredump[15813]: Process 15809 (firefox) of user 1000 dumped core.
May 25 06:15:07 susetest systemd-coredump[15811]: Process 15803 (firefox) of user 1000 dumped core.
May 25 06:21:15 susetest systemd[1]: Started Getty on tty5.
===

[Build 20180524] openQA test fails in firefox
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-ppc64le-system_performance@ppc64le fails in
[firefox](https://openqa.opensuse.org/tests/682425/modules/firefox/steps/4)


## Reproducible

Fails since (at least) Build [20180524](https://openqa.opensuse.org/tests/682425) (current job)


## Expected result

Last good: (unknown) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=ppc64le&flavor=DVD&test=system_performance&machine=ppc64le&version=Tumbleweed&distri=opensuse)
Comment 1 Michel Normand 2018-05-25 10:53:17 UTC
I did not analysed yet data uploaded by openqa in 
https://openqa.opensuse.org/tests/682425#downloads


FYIO, There is a recent Fedora bug https://bugzilla.redhat.com/show_bug.cgi?id=1498561 that when solved allow firefox to run on ppc64le on fedora.
Comment 2 Oliver Kurz 2018-06-08 06:38:40 UTC
fedora bug was closed referencing https://bugzilla.mozilla.org/show_bug.cgi?id=1462566 with bugfixes available
in upstream 61.0b8 and ESR 60.1 , see
https://hg.mozilla.org/releases/mozilla-beta/rev/323494cc7e95 and
https://hg.mozilla.org/releases/mozilla-esr60/rev/d5eb098522b5

I guess one could try to apply the upstream patch to the package for now.
Comment 19 Jonathan Brielmaier 2020-01-27 14:56:40 UTC
Firefox starts now a days on ppc64le as I use it on my Power workstation. So I guess this can be closed?
Comment 20 Wolfgang Rosenauer 2020-01-27 15:03:06 UTC
closing as suggested