Bug 1094627 - neovim mouse support is broken due to incompatibility with libtermkey library
neovim mouse support is broken due to incompatibility with libtermkey library
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Martin Liška
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-25 07:36 UTC by Martin Liška
Modified: 2019-02-12 11:08 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2018-05-25 07:36:09 UTC
One needs to bump libtermkey to version 0.20. Done here:

https://build.opensuse.org/request/show/611513
https://build.opensuse.org/request/show/611514
Comment 1 Swamp Workflow Management 2018-05-25 08:10:08 UTC
This is an autogenerated message for OBS integration:
This bug (1094627) was mentioned in
https://build.opensuse.org/request/show/612196 Factory / neovim
Comment 2 Martin Liška 2018-06-11 06:50:08 UTC
Fixed.
Comment 3 Swamp Workflow Management 2018-12-08 18:10:07 UTC
This is an autogenerated message for OBS integration:
This bug (1094627) was mentioned in
https://build.opensuse.org/request/show/656415 15.0 / libtermkey+lua51-bit32+neovim+python-neovim
Comment 4 Swamp Workflow Management 2019-02-08 11:10:47 UTC
openSUSE-RU-2019:0151-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1094627,1098800,1100496
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    libtermkey-0.20-lp150.2.3.1, lua51-bit32-5.3.0-lp150.2.1, neovim-0.3.1-lp150.2.3.1, python-neovim-0.3.1-lp150.2.3.1
Comment 5 Swamp Workflow Management 2019-02-12 11:08:46 UTC
openSUSE-RU-2019:0157-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1094627,1098800,1100496
CVE References: 
Sources used:
openSUSE Backports SLE-15 (src):    libtermkey-0.20-bp150.3.3.1, lua51-bit32-5.3.0-bp150.2.1, neovim-0.3.1-bp150.2.3.1, python-neovim-0.3.1-bp150.3.3.1