Bug 1094376 - kactivitymanagerd crashes
kactivitymanagerd crashes
Status: RESOLVED DUPLICATE of bug 1093567
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
x86-64 SUSE Other
: P5 - None : Major (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-23 15:17 UTC by Albert Hensel
Modified: 2018-05-23 15:30 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
backtrace kactivitymanagerd crash (14.07 KB, text/x-log)
2018-05-23 15:17 UTC, Albert Hensel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Hensel 2018-05-23 15:17:39 UTC
Created attachment 771124 [details]
backtrace kactivitymanagerd crash

kactivitymanagerd always immediately crashes and restarts again, filling /var/lib/systemd/coredump if coredumps are enabled. A backtrace taken with "coredumpctl gdb /usr/bin/kactivitymanagerd" is attached.

$ rpm -qi kactivitymanagerd
Version     : 5.12.5
Release     : 1.1
Architecture: x86_64
Build Date  : Di 08 Mai 2018 14:06:40 CEST
Distribution: openSUSE Tumbleweed
Comment 1 Wolfgang Bauer 2018-05-23 15:27:12 UTC
> "KActivities: Database can not be opened in WAL mode. Check the SQLite version (required >3.7.0). And whether your filesystem supports shared memory"

Your activities database is corrupted and cannot be opened. Delete ~/.local/share/kacivitymanagerd/ to recreate it from scratch.
(You will lose favorites though and the history of recently opened files/applications though, I think)

KDE Frameworks 5.46.0 (that already has been submitted to Factory and should appear in Tumbleweed soon) will fix that crash, but kactivitymanagerd will run in "read-only" mode then and not save anything.

The long-term upstream plan is to backup the database regularly and restore it in case of problems, AFAIK.

*** This bug has been marked as a duplicate of bug 1093567 ***
Comment 2 Wolfgang Bauer 2018-05-23 15:30:04 UTC
(In reply to Wolfgang Bauer from comment #1)
> KDE Frameworks 5.46.0 (that already has been submitted to Factory and should
> appear in Tumbleweed soon) will fix that crash, but kactivitymanagerd will
> run in "read-only" mode then and not save anything.

Sorry, that change/fix will be in Plasma/kactivitymanagerd 5.13.

* Sat May 19 2018 fabian@ritter-vogt.de
- Update to 5.12.90
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
...
  * Allowing KAMD to run without a database backend <=====
...