Bug 1093567 - kactivity continually crashing
kactivity continually crashing
Status: RESOLVED FIXED
: 1094376 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-16 17:46 UTC by Petr Matula
Modified: 2018-05-23 15:27 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
wbauer: needinfo? (petr.m)


Attachments
errors log (4.17 KB, application/gzip)
2018-05-16 17:46 UTC, Petr Matula
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Matula 2018-05-16 17:46:33 UTC
Created attachment 770486 [details]
errors log

kactivity continually crashing after zypper dup
Comment 1 Wolfgang Bauer 2018-05-16 19:01:35 UTC
(In reply to Petr Matula from comment #0)
> kactivity continually crashing after zypper dup

What does that mean exactly?
Is kactivitymanagerd crashing every time you run "zypper dup", or is it now crashing everytime on start since the last "zypper dup"?

In the latter case, it's probably just coincidence, as there hasn't been an update to kactivitymanagerd recently.

I notice this in the attached log:
KActivities: Database can not be opened in WAL mode. Check the SQLite version (required >3.7.0). And whether your filesystem supports shared memory

That probably means that the database is corrupted (or cannot be opened for some reason).
Deleting ~/.local/share/kactivitymanagerd/ should fix the problem in that case You will lose favorites though and the history of recently opened files/applications, I think, but that's the only way to "fix" it anyway AFAIK.
Comment 2 Petr Matula 2018-05-16 19:42:35 UTC
Thanks. Deleting ~/.local/share/kactivitymanagerd/ have fixed the problem.
Comment 3 Wolfgang Bauer 2018-05-23 15:27:12 UTC
*** Bug 1094376 has been marked as a duplicate of this bug. ***