Bug 1093111 - YaST uses deprecated firewallctl commands instead of firewall-cmd (introduced by firewalld upgrade to 0.5.1)
YaST uses deprecated firewallctl commands instead of firewall-cmd (introduced...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
All Other
: P5 - None : Normal (vote)
: ---
Assigned To: Knut Alejandro Anderssen González
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-14 10:51 UTC by Oliver Kurz
Modified: 2022-09-12 10:25 UTC (History)
8 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Kurz 2018-05-14 10:51:32 UTC
+++ This bug was initially created as a clone of Bug #1084026 +++

firewalld upgrade to 0.5.1 has caused error messages in the yast log as can be seen in https://openqa.opensuse.org/tests/674858#step/yast2_dns_server/46 because apparently yast internally uses the deprecated "firewallctl" command.
Comment 1 Martin Vidner 2018-05-14 15:14:09 UTC
Thanks for the report!

Apparently we only call firewallctl from a single place:

https://github.com/yast/yast-yast2/blob/d7d529ab50510ccf0d364fb8f50c1626a04b25c2/library/network/src/lib/y2firewall/firewalld/api.rb#L108
Comment 2 Knut Alejandro Anderssen González 2018-05-15 09:31:17 UTC
Replacement proposed https://github.com/yast/yast-yast2/pull/736
Comment 3 Knut Alejandro Anderssen González 2018-05-15 11:41:31 UTC
It will be fixed in yast2-4.0.74

SR: https://build.opensuse.org/request/show/607494
Comment 4 Oliver Kurz 2018-05-15 12:15:12 UTC
awesome!
Comment 12 Swamp Workflow Management 2018-10-05 16:10:12 UTC
SUSE-RU-2018:3023-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1080738,1093111,1096027,1098910,1104568
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Basesystem 15 (src):    yast2-4.0.87-3.12.1, yast2-services-manager-4.0.7-3.4.4
Comment 13 Swamp Workflow Management 2018-10-06 16:15:08 UTC
openSUSE-RU-2018:3060-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1080738,1093111,1096027,1098910,1104568
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    yast2-4.0.87-lp150.2.9.1, yast2-services-manager-4.0.7-lp150.2.3.1