Bug 1093037 - Avogadro 1.2.0 crashes on startup: undefined symbol _ZN9OpenBabel5OBMol8NextBondERN9__gnu_cxx17__normal_iteratorIPPNS_6OBBondESt6vectorIS4_SaIS4_EEEE
Avogadro 1.2.0 crashes on startup: undefined symbol _ZN9OpenBabel5OBMol8NextB...
Status: NEW
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 Applications
Current
x86-64 Linux
: P5 - None : Normal with 5 votes (vote)
: ---
Assigned To: Dmitry Roshchin
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-13 11:14 UTC by Brenton Horne
Modified: 2018-05-26 05:07 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
LD_DEBUG=libs avogadro output (7.14 KB, text/x-log)
2018-05-13 11:14 UTC, Brenton Horne
Details
strace avogadro output (27.32 KB, text/x-log)
2018-05-13 11:15 UTC, Brenton Horne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brenton Horne 2018-05-13 11:14:32 UTC
Created attachment 769990 [details]
LD_DEBUG=libs avogadro output

Avogadro 1.2.0 crashes on startup on openSUSE Tumbleweed 20180502, giving the error:

avogadro: symbol lookup error: /usr/lib64/libavogadro.so.1: undefined symbol: _ZN9OpenBabel5OBMol8NextBondERN9__gnu_cxx17__normal_iteratorIPPNS_6OBBondESt6vectorIS4_SaIS4_EEEE

which to me indicates a rebuild may be needed for Avogadro against a new build of OpenBabel. My OpenBabel version is 2.4.1-18.5. I should mention I have the Education repository enabled and both Avogadro and Openbabel packages seems to be from this repository (precise package revision is 1.2.0-5.3). As this seems like too little information to provide I ran:

LD_DEBUG=libs avogadro

and that gave the attached output. Likewise strace avogadro gave: https://gist.github.com/231f06f4de25f9d91286b6bd643b17a7.
Comment 1 Brenton Horne 2018-05-13 11:15:07 UTC
Created attachment 769991 [details]
strace avogadro output
Comment 2 Doryx _ 2018-05-21 16:52:34 UTC
On the most recent version of tumbleweed:

NAME="openSUSE Tumbleweed"
# VERSION="20180520"
ID="opensuse-tumbleweed"
ID_LIKE="opensuse suse"
VERSION_ID="20180520"
PRETTY_NAME="openSUSE Tumbleweed"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20180520"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"

avogadro crashes right away, and when running from terminal:

$ avogadro
avogadro: symbol lookup error: /usr/lib64/libavogadro.so.1: undefined symbol: _ZN9OpenBabel5OBMol12SetConformerEi

Here is a link to the output of "ldd /usr/bin/avogadro" http://paste.opensuse.org/43054496


I've removing the avogadro package (including libavogadro1 which provides libavogadro.so.1) and re-installing without any luck.

So I think I have the same problem.
Comment 3 Doryx _ 2018-05-23 17:45:25 UTC
Not sure what fixed it, but a dup (# VERSION="20180521") and re-install fixed it for me.
Comment 4 Brenton Horne 2018-05-26 05:07:22 UTC
Didn't fix it for me.