Bug 1093033 - [Build 20180511] openQA test fails in consoletest_setup, curl failed with Could not connect to Server
[Build 20180511] openQA test fails in consoletest_setup, curl failed with Cou...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
PowerPC All
: P5 - None : Normal (vote)
: ---
Assigned To: Wolfgang Rosenauer
Jiri Srain
https://openqa.opensuse.org/tests/675...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-13 04:42 UTC by Michel Normand
Modified: 2018-11-17 23:50 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
polkit_service_segv.png (171.64 KB, image/png)
2018-05-13 06:45 UTC, Michel Normand
Details
mozjs52-spec_ppc64.patch (475 bytes, patch)
2018-05-30 10:15 UTC, Michel Normand
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Normand 2018-05-13 04:42:26 UTC
The consoletest_setup script is failing because curl is not able to access the 

## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-ppc64-lvm@ppc64 fails in
[consoletest_setup](https://openqa.opensuse.org/tests/675265/modules/consoletest_setup/steps/29)


## Reproducible

Fails since (at least) Build [20180427](https://openqa.opensuse.org/tests/665973)


## Expected result

Last good: [20180425](https://openqa.opensuse.org/tests/663532) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?machine=ppc64&arch=ppc64&test=lvm&flavor=DVD&distri=opensuse&version=Tumbleweed)
Comment 1 Michel Normand 2018-05-13 04:49:34 UTC
Seems to be specific to ppc64 (BE) as no such failure for ppc64le:
https://openqa.opensuse.org/tests/675245#step/consoletest_setup/29
Comment 2 Michel Normand 2018-05-13 05:43:46 UTC
May be related to "systemd[1]: Failed to start Authorisation Manager" as per https://openqa.opensuse.org/tests/675265#step/consoletest_setup/53

How to continue investigation ?
Comment 3 Michel Normand 2018-05-13 06:45:58 UTC
Created attachment 769987 [details]
polkit_service_segv.png

in attached png file, I captured the output of systemctl status polkit.service; that reports a SEGV error cause.
Comment 4 Josef Reidinger 2018-05-15 09:49:16 UTC
Lets reassign it to polkit developer. I am not sure if we support ppc64be ?
Comment 5 Michel Normand 2018-05-15 10:10:58 UTC
(In reply to Josef Reidinger from comment #4)
> Lets reassign it to polkit developer. I am not sure if we support ppc64be ?

it worked on ppc64 (BE) on previous version (at least polkit 0.113-7.1.ppc64)
Comment 6 Michel Normand 2018-05-29 16:36:30 UTC
Bjorn as owner of the last change 0.114, 
Do you have a suggestion to capture more data to investigate why polkit.service failed to start:

===
[michel@twppc64be:~]
$sudo systemctl status  polkit.service
 polkit.service - Authorization Manager
   Loaded: loaded (/usr/lib/systemd/system/polkit.service; static; vendor preset: disabled)
   Active: failed (Result: signal) since Tue 2018-05-29 18:21:23 CEST; 2min 50s ago
     Docs: man:polkit(8)
  Process: 1863 ExecStart=/usr/lib/polkit-1/polkitd --no-debug (code=killed, signal=SEGV)
 Main PID: 1863 (code=killed, signal=SEGV)

mai 29 18:21:23 twppc64be systemd[1]: Starting Authorization Manager...
mai 29 18:21:23 twppc64be polkitd[1863]: Started polkitd version 0.114
mai 29 18:21:23 twppc64be systemd[1]: polkit.service: Main process exited, code=killed, status=11/SEGV
mai 29 18:21:23 twppc64be systemd[1]: polkit.service: Failed with result 'signal'.
mai 29 18:21:23 twppc64be systemd[1]: Failed to start Authorization Manager.
[michel@twppc64be:~]
$sudo systemctl restart  polkit
Job for polkit.service failed because a fatal signal was delivered to the control process.
See "systemctl status polkit.service" and "journalctl -xe" for details.
===
Comment 7 Michel Normand 2018-05-30 10:15:23 UTC
Created attachment 771804 [details]
mozjs52-spec_ppc64.patch

Able to retrieve backtrace with gdb, as detailed below.
This is pointing to a SEGV in libmozjs52.

I did a trial with a mozjs52.spec change; after build and install I was able to start with no error the polkitd.

===
gdb /usr/lib/polkit-1/polkitd
...
Thread 1 "polkitd" received signal SIGSEGV, Segmentation fault.
js::detail::MutexImpl::lock (this=0x188) at /usr/src/debug/mozjs52-52.6.0-3.1.ppc64/js/src/threading/posix/MutexImpl.cpp:70
70        TRY_CALL_PTHREADS(pthread_mutex_lock(&platformData()->ptMutex),
(gdb) bt
#0  js::detail::MutexImpl::lock (this=0x188) at /usr/src/debug/mozjs52-52.6.0-3.1.ppc64/js/src/threading/posix/MutexImpl.cpp:70
#1  0x00007ffff66c719c in js::LockGuard<js::Mutex>::LockGuard (aLock=..., this=<synthetic pointer>) at /usr/src/debug/mozjs52-52.6.0-3.1.ppc64/js/src/threading/LockGuard.h:25
#2  js::AutoLockHelperThreadState::AutoLockHelperThreadState (this=<synthetic pointer>) at /usr/src/debug/mozjs52-52.6.0-3.1.ppc64/js/src/vm/HelperThreads.h:511
#3  js::GlobalHelperThreadState::ensureInitialized (this=0x0) at /usr/src/debug/mozjs52-52.6.0-3.1.ppc64/js/src/vm/HelperThreads.cpp:704
#4  0x00007ffff6722774 in JSRuntime::init (this=0x1000c9ec0, maxbytes=<optimized out>, maxNurseryBytes=<optimized out>)
    at /usr/src/debug/mozjs52-52.6.0-3.1.ppc64/js/src/vm/Runtime.cpp:292
#5  0x00007ffff65339c0 in JSContext::init (maxNurseryBytes=16777216, maxBytes=8388608, this=0x1000c9cc0) at /usr/src/debug/mozjs52-52.6.0-3.1.ppc64/js/src/jscntxt.cpp:96
#6  js::NewContext (parentRuntime=0x0, maxNurseryBytes=16777216, maxBytes=8388608) at /usr/src/debug/mozjs52-52.6.0-3.1.ppc64/js/src/jscntxt.cpp:112
#7  JS_NewContext (maxbytes=<optimized out>, maxNurseryBytes=<optimized out>, parentContext=<optimized out>) at /usr/src/debug/mozjs52-52.6.0-3.1.ppc64/js/src/jsapi.cpp:476
#8  0x0000000100012ebc in polkit_backend_js_authority_constructed (object=0x100087900) at polkitbackendjsauthority.cpp:453
#9  0x00007ffff7c06b10 in ?? () from /usr/lib64/libgobject-2.0.so.0
#10 0x00007ffff7c08a10 in .g_object_new_with_properties () from /usr/lib64/libgobject-2.0.so.0
#11 0x00007ffff7c0952c in .g_object_new () from /usr/lib64/libgobject-2.0.so.0
#12 0x0000000100010348 in polkit_backend_authority_get () at polkitbackendauthority.c:1434
#13 0x000000010000e0b8 in main (argc=<optimized out>, argv=<optimized out>) at polkitd.c:219
===
Comment 8 Marcus Meissner 2018-05-30 11:27:40 UTC
Wolfgang, can you add this patch to mozjs52?
Comment 9 Michel Normand 2018-05-30 11:53:55 UTC
(In reply to Marcus Meissner from comment #8)
> Wolfgang, can you add this patch to mozjs52?

I just create an osc sr#613045 with mimimal patch
not yet build complete in OBS, but validated locally by successfull start of polkitd.
https://build.opensuse.org/request/show/613045
Comment 10 Wolfgang Rosenauer 2018-05-30 12:10:06 UTC
thanks, waiting for Factory acceptance
Comment 12 Michel Normand 2018-06-18 16:03:21 UTC
FYIO, need a _constraints change to avoid transient OBS build failure,
tracked by another PR https://build.opensuse.org/request/show/617547
before to be able to confirm  correction of this bug.
Comment 13 Michel Normand 2018-06-22 10:14:36 UTC
still waiting for the _constraint change to reach TW, as today still in Staging:E with PR https://build.opensuse.org/request/show/617548
Comment 14 Michel Normand 2018-07-02 07:25:22 UTC
(In reply to Michel Normand from comment #13)
> still waiting for the _constraint change to reach TW, as today still in
> Staging:E with PR https://build.opensuse.org/request/show/617548

moved from Staging: to Staging:F and still waiting :(
https://build.opensuse.org/project/show/openSUSE:Factory:Staging:F
Comment 16 Michel Normand 2018-08-06 09:00:00 UTC
correction was available in snapshot 20180704 and no more such failure in o3 since then:
https://openqa.opensuse.org/tests/overview?distri=opensuse&version=Tumbleweed&build=20180704&groupid=4
Comment 17 Swamp Workflow Management 2018-09-27 13:22:32 UTC
SUSE-RU-2018:2896-1: An update that has two recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1082720,1093033
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Desktop Applications 15 (src):    mozjs52-52.6.0-3.3.2
SUSE Linux Enterprise Module for Basesystem 15 (src):    mozjs52-52.6.0-3.3.2
Comment 18 Swamp Workflow Management 2018-09-27 22:21:02 UTC
openSUSE-RU-2018:2920-1: An update that has two recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1082720,1093033
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    mozjs52-52.6.0-lp150.2.3.1