Bug 1092950 - Crash in yast2-bootloader
Crash in yast2-bootloader
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/Y2NOuM2Z
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-05-11 14:29 UTC by Christian Hägele
Modified: 2021-11-19 12:35 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Most recent y2log (all logs are too big) (7.90 MB, text/plain)
2018-05-11 14:33 UTC, Christian Hägele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Hägele 2018-05-11 14:29:38 UTC
I edited the settings and wrote UUID="98b7902f-8b9e-47b1-bb33-27308d312498" in the field for "user defined boot partition".

Since that the module crashes telling me I should do a bug-report.
Comment 1 Christian Hägele 2018-05-11 14:33:39 UTC
Created attachment 769917 [details]
Most recent y2log (all logs are too big)
Comment 2 Martin Vidner 2018-05-14 12:45:36 UTC
Thanks for the report!

Please attach the complete logs: use the tool save_y2logs, which compresses the logs making them fit inside Bugzilla.
Comment 3 Martin Vidner 2018-05-14 12:47:54 UTC
Josef, to me it seems that the problem is not a non-matching UUID but that Christian is asking YaST to do something that YaST does not understand: a UUID in the name field. Is that right?

Nevertheless, we should present a better error message, not an Internal Error.
Comment 4 Josef Reidinger 2018-05-14 12:54:36 UTC
this is wrong entry, it should be /dev/disks/by-uuid/98b7902f-8b9e-47b1-bb33-27308d31249

but I agree we should not crash.
Comment 5 Christian Hägele 2018-05-15 16:12:44 UTC
I can agree with Josef Reidinger.
I should have put a different format in the Input-Field. But how can I change it now? Where is this field stored at?

Right now the Yast-Module is unusable for me. Is there some workaround?
Comment 6 Josef Reidinger 2018-05-16 06:28:47 UTC
(In reply to Christian Hägele from comment #5)
> I can agree with Josef Reidinger.
> I should have put a different format in the Input-Field. But how can I
> change it now? Where is this field stored at?
> 
> Right now the Yast-Module is unusable for me. Is there some workaround?

Well, there are two options:

1. start it and it should allow to propose from scratch ( together with broken configuration )

2. modify /etc/default/grub_installdevices yourself to have dev in expected format
Comment 7 Stefan Hundhammer 2018-06-06 14:12:44 UTC
(In reply to Christian Hägele from comment #1)
> Created attachment 769917 [details]
> Most recent y2log (all logs are too big)

This is ONE reason why we provide that save_y2logs script: It uses a compressed tarball. The other reason is that we typically need other files that this script also collects.
Comment 8 Stefan Hundhammer 2018-06-06 14:16:10 UTC
So, the conclusion of this appears to be that we should check what the user enters in that input field and either reject a bad format or, in the deluxe version, convert "UUID=..." to "/dev/disk/by-uuid/...".

Either way, we don't seem to need more y2logs for that, so this has been in NEEDINFO for too long.
Comment 9 Stefan Hundhammer 2018-06-06 14:45:39 UTC
Now tracking in our Trello scrum task queue:

  https://trello.com/c/Y2NOuM2Z
Comment 10 Michal Filka 2021-11-18 10:52:08 UTC
Fixed in yast2-bootloader 4.4.8