Bug 1091353 - [Build 20180417] openQA test fails to install inkscape over pkcon sporadically
[Build 20180417] openQA test fails to install inkscape over pkcon sporadically
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
https://openqa.opensuse.org/tests/658...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-30 09:40 UTC by Oliver Kurz
Modified: 2020-12-29 16:26 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
pk_backend_zypp files from both the "failed" as well as "good" case for comparison. (163.47 KB, application/x-xz)
2018-04-30 09:40 UTC, Oliver Kurz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Kurz 2018-04-30 09:40:09 UTC
Created attachment 768621 [details]
pk_backend_zypp files from both the "failed" as well as "good" case for comparison.

## Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-zdup-Leap-42.2-gnome@64bit fails in
[inkscape](https://openqa.opensuse.org/tests/658802/modules/inkscape/steps/12)


## Reproducible

Sporadically reproduced, see openQA test scenario, especially in upgrade cases.


## Expected result

See [20180416](https://openqa.opensuse.org/tests/657426) how it should look like. https://openqa.opensuse.org/tests/660733#step/inkscape/13 shows the expected screen


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?test=zdup-Leap-42.2-gnome&distri=opensuse&version=Tumbleweed&arch=x86_64&machine=64bit&flavor=NET)

I looked up the corresponding pk_backend_zypp logfiles for the "failed" and "good" case, see pk_backend_zypp_failed_good.tar.xz for that. Complete logfiles for "failed" are available in https://openqa.opensuse.org/tests/658802#downloads and correspondingly in https://openqa.opensuse.org/tests/660733#downloads for "good".
Comment 1 Dominique Leuenberger 2018-04-30 09:58:29 UTC
Looking at the logs, the main difference seems to be:

GOOD
*****
>2018-04-22 11:29:51 <1> susetest(2815) [packagekit] pk-backend-zypp.cpp(backend_resolve_thread):2853 found (586)inkscape-0.92.2-6.2.x86_64(@System)
>2018-04-22 11:29:51 <1> susetest(2815) [packagekit] pk-backend-zypp.cpp(backend_resolve_thread):2853 found (18816)inkscape-0.92.2-6.2.x86_64(repo1)
>2018-04-22 11:29:51 <1> susetest(2815) [packagekit] pk-backend-zypp.cpp(backend_resolve_thread):2864 emit (18816)inkscape-0.92.2-6.2.x86_64(repo1)
>2018-04-22 11:29:51 <1> susetest(2815) [packagekit] pk-backend-zypp.cpp(backend_resolve_thread):2853 found (18815)inkscape-0.92.2-6.2.i586(repo1)
>2018-04-22 11:29:51 <1> susetest(2815) [packagekit] pk-backend-zypp.cpp(backend_resolve_thread):2873 emit just newest (18816)inkscape-0.92.2-6.2.x86_64(repo1)

BAD
*****
>2018-04-24 18:18:44 <1> susetest(2205) [packagekit] pk-backend-zypp.cpp(backend_resolve_thread):2825 inkscape ~installed;newest;arch;~source
>2018-04-24 18:18:44 <1> susetest(2205) [packagekit] pk-backend-zypp.cpp(backend_resolve_thread):2853 found (581)inkscape-0.92.2-6.2.x86_64(@System)

In the BAD case, no repo* info was found
Comment 2 Dominik Heidler 2018-06-11 13:33:10 UTC
Happened here again: https://openqa.opensuse.org/tests/687478#step/wine/17
Comment 39 Dominique Leuenberger 2020-12-29 16:26:51 UTC
This was never reproducible outside of openQA and openQA code changed sufficiently to no longer trigger it neither (IIRC always using zypper now)