Bug 1091300 - xfsprogs v4.16.0 package build failure
xfsprogs v4.16.0 package build failure
Status: RESOLVED FIXED
: 1091299 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-28 21:49 UTC by Luis Chamberlain
Modified: 2021-09-08 18:35 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Chamberlain 2018-04-28 21:49:41 UTC
Building the xfsprogs-4.16.0 fails on Tumbelweed with the following lint complaint:

E: shlib-policy-name-error (Badness: 10000) libhandle1
 Your package contains a single shared library but is not named after its SONAME

The reason this is failing is it seems the lint is now strict and requiring that packages which carry their own .so files do this with its own dedicated package. This is documented here:

https://en.opensuse.org/openSUSE:Shared_library_packaging_policy
Comment 1 Luis Chamberlain 2018-04-28 21:51:08 UTC
As per the opensuse documentation, we need 3 packages then for xfsprogs:

  * xfsprogs
  * libhanldle1 - for libhandle.so.1 and libhandle.so.1.0.3
  * xfsprogs-devel - for libhandle.so, and the static archive file libhandle.a and the libtool description file libhandle.la

The alternative is to get libhandle renamed to libxfshandle but this needs to be done upstream first and that is a significant churn. Since we have been carrying the so file with the same libhandle name, lets just deal with the fact that the libhandle filename was used.
Comment 2 Andreas Stieger 2018-04-29 12:22:50 UTC
*** Bug 1091299 has been marked as a duplicate of this bug. ***
Comment 3 Luis Chamberlain 2018-05-02 21:18:01 UTC
Fix submitted, request ID 603232
Comment 4 Luis Chamberlain 2018-05-10 23:40:31 UTC
Submission accepted.