Bug 1091299 - xfsprogs v4.16.0 package build failure
xfsprogs v4.16.0 package build failure
Status: RESOLVED DUPLICATE of bug 1091300
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on: 1090290
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-28 21:49 UTC by Luis Chamberlain
Modified: 2018-04-29 12:22 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Chamberlain 2018-04-28 21:49:34 UTC
Building the xfsprogs-4.16.0 fails on Tumbelweed with the following lint complaint:

E: shlib-policy-name-error (Badness: 10000) libhandle1
 Your package contains a single shared library but is not named after its SONAME

The reason this is failing is it seems the lint is now strict and requiring that packages which carry their own .so files do this with its own dedicated package. This is documented here:

https://en.opensuse.org/openSUSE:Shared_library_packaging_policy
Comment 1 Andreas Stieger 2018-04-29 12:22:49 UTC
one is sufficient

*** This bug has been marked as a duplicate of bug 1091300 ***