Bug 1091286 - libyui-qt{,-pkg,graph} does not build with Qt 5.11
libyui-qt{,-pkg,graph} does not build with Qt 5.11
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P2 - High : Normal (vote)
: ---
Assigned To: Imobach Gonzalez Sosa
Jiri Srain
https://trello.com/c/YyR8TRRl
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-28 07:42 UTC by Fabian Vogt
Modified: 2021-03-23 09:37 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Vogt 2018-04-28 07:42:23 UTC
The cmake command qt5_use_modules was deprecated for a while now, it got removed with Qt 5.11.
Comment 3 Fabian Vogt 2018-05-24 09:38:27 UTC
Not fixed for libyui-qt-graph.

The PR is broken: https://github.com/libyui/libyui-qt-graph/pull/21/files

It added target_link_libraries but did not remove qt5_use_modules.
Comment 4 Imobach Gonzalez Sosa 2018-05-24 10:51:39 UTC
Sorry, Fabian, this PR should make it: https://github.com/libyui/libyui-qt-graph/pull/22
Comment 5 Imobach Gonzalez Sosa 2018-05-31 08:13:59 UTC
The fix was submitted a few days ago: https://build.opensuse.org/request/show/612208. For the time being, I am closing this bug report.

Thanks!