Bug 1090456 - amdgpu [RX Vega 64] system freeze while gaming
amdgpu [RX Vega 64] system freeze while gaming
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
x86-64 Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-21 15:02 UTC by Mauro Gaspari
Modified: 2019-01-26 19:54 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
EVElauncher-crash (73.47 KB, image/jpeg)
2018-10-22 13:08 UTC, Mauro Gaspari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mauro Gaspari 2018-04-21 15:02:14 UTC
OS: OpenSUSE tumbleweed x86_64 updated (2018 04 21)
Kernel: 4.16.2-1-default
Desktop Environment: KDE Plasma (x11)
OpenGL version string: 3.0 Mesa 18.0.0
GPU: AMD Radeon RX Vega 64 8GB

Symptoms:
During gaming sessions, system locks up and freezes completely. Audio seems to keep working for a few seconds more, but full desktop is frozen, no mouse and keyboard actions available. Hard reset only possible action on local pc. I have not tried to ssh in the PC from another box.
I noticed this on both games running through wine, and native games via steam. Some times I can play for 20 minutes, some times for a few hours. Freezes seem unrelated to any activity running in-game. All system temperatures are under control.
The system outside of 3d gaming is very stable, including playing videos, encoding videos, regular desktop usage.

I am trying to gather more logs. This is what I have for now:

System Logs:

Apr 21 17:08:34 STUDIO kernel: [drm:gfx_v9_0_priv_reg_irq [amdgpu]] *ERROR* Illegal register access in command stream
Apr 21 17:08:34 STUDIO kernel: [drm] No hardware hang detected. Did some blocks stall?
Apr 21 17:08:44 STUDIO kernel: [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx timeout, last signaled seq=128859, last emitted seq=128861
Apr 21 17:08:44 STUDIO kernel: [drm] No hardware hang detected. Did some blocks stall?
-- Reboot --


Dmesg lines relative to amdgpu:

[    3.407020] [drm] amdgpu kernel modesetting enabled.
[    3.411462] fb: switching to amdgpudrmfb from VESA VGA
[    3.426163] amdgpu 0000:04:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff
[    3.426261] amdgpu 0000:04:00.0: VRAM: 8176M 0x000000F400000000 - 0x000000F5FEFFFFFF (8176M used)
[    3.426263] amdgpu 0000:04:00.0: GTT: 256M 0x000000F600000000 - 0x000000F60FFFFFFF
[    3.426371] [drm] amdgpu: 8176M of VRAM memory ready
[    3.426372] [drm] amdgpu: 8176M of GTT memory ready.
[    4.031665] fbcon: amdgpudrmfb (fb0) is primary device
[    4.083803] amdgpu 0000:04:00.0: fb0: amdgpudrmfb frame buffer device
[    4.096086] amdgpu 0000:04:00.0: ring 0(gfx) uses VM inv eng 4 on hub 0
[    4.096088] amdgpu 0000:04:00.0: ring 1(comp_1.0.0) uses VM inv eng 5 on hub 0
[    4.096089] amdgpu 0000:04:00.0: ring 2(comp_1.1.0) uses VM inv eng 6 on hub 0
[    4.096090] amdgpu 0000:04:00.0: ring 3(comp_1.2.0) uses VM inv eng 7 on hub 0
[    4.096091] amdgpu 0000:04:00.0: ring 4(comp_1.3.0) uses VM inv eng 8 on hub 0
[    4.096093] amdgpu 0000:04:00.0: ring 5(comp_1.0.1) uses VM inv eng 9 on hub 0
[    4.096094] amdgpu 0000:04:00.0: ring 6(comp_1.1.1) uses VM inv eng 10 on hub 0
[    4.096095] amdgpu 0000:04:00.0: ring 7(comp_1.2.1) uses VM inv eng 11 on hub 0
[    4.096096] amdgpu 0000:04:00.0: ring 8(comp_1.3.1) uses VM inv eng 12 on hub 0
[    4.096098] amdgpu 0000:04:00.0: ring 9(kiq_2.1.0) uses VM inv eng 13 on hub 0
[    4.096099] amdgpu 0000:04:00.0: ring 10(sdma0) uses VM inv eng 4 on hub 1
[    4.096100] amdgpu 0000:04:00.0: ring 11(sdma1) uses VM inv eng 5 on hub 1
[    4.096101] amdgpu 0000:04:00.0: ring 12(uvd) uses VM inv eng 6 on hub 1
[    4.096103] amdgpu 0000:04:00.0: ring 13(uvd_enc0) uses VM inv eng 7 on hub 1
[    4.096104] amdgpu 0000:04:00.0: ring 14(uvd_enc1) uses VM inv eng 8 on hub 1
[    4.096105] amdgpu 0000:04:00.0: ring 15(vce0) uses VM inv eng 9 on hub 1
[    4.096107] amdgpu 0000:04:00.0: ring 16(vce1) uses VM inv eng 10 on hub 1
[    4.096108] amdgpu 0000:04:00.0: ring 17(vce2) uses VM inv eng 11 on hub 1
[    4.096662] [drm] Initialized amdgpu 3.23.0 20150101 for 0000:04:00.0 on minor 0
Comment 1 Takashi Iwai 2018-04-30 12:06:57 UTC
Possibly the same issue as the upstream bug?
  https://bugs.freedesktop.org/show_bug.cgi?id=105317

A fix patch for Mesa was suggested there.  Reassigned to X.Org component for taking care of that fix.
Comment 2 Max Staudt 2018-04-30 13:50:10 UTC
(In reply to Takashi Iwai from comment #1)
> Possibly the same issue as the upstream bug?
>   https://bugs.freedesktop.org/show_bug.cgi?id=105317
> 
> A fix patch for Mesa was suggested there.  Reassigned to X.Org component for
> taking care of that fix.

That fix is already in Mesa 18.0.1, which is in Factory.

Mauro, can you please check the Mesa version you have installed?

  rpm -q Mesa

It should be something along the lines of Mesa-18.0.1-...

If it's not, then please try updating your system:

  sudo zypper refresh
  sudo zypper dup
Comment 3 Mauro Gaspari 2018-04-30 14:14:40 UTC
Takashi,
yes it looks exactly the same bug as   https://bugs.freedesktop.org/show_bug.cgi?id=105317.

Max,
I updated my Tumbleweed system a few days ago and I saw mesa was updated to 18.0.1. Since then, I have not experienced a single system freeze. It looks like the fix was successful, I am not seeing any error in my logs.

I got a bit busy with work so I did not have the chance to run very long gaming sessions. If you prefer to hold on a few days before closing this bug, I can report back next Monday with more feedback.
Comment 4 Max Staudt 2018-04-30 14:59:51 UTC
That's great news, thanks Mauro!
Also, thanks Takashi for spotting the upstream bug!

Let's do it the other way around - I'll close the bug now so it doesn't stay stale, and if the problem comes back, you can simply change the status to REOPENED to raise our attention.

Thanks for reporting! :)
Comment 5 Mauro Gaspari 2018-08-10 00:50:13 UTC
Reopening this bug as it seems it started again last night. Updating system info:

OS: OpenSUSE tumbleweed x86_64 updated (2018 08 10)
Kernel: 4.17.2-1-default
Desktop Environment: KDE Plasma (x11)
OpenGL version string: 3.1 Mesa 18.1.5
GPU: AMD Radeon RX Vega 64 8GB


Relevant log lines I found during freeze:

2018-08-09T23:16:53.103775+08:00 MGDT-Tumbleweed kernel: [ 6305.852703] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx timeout, last signaled seq=1745163, last emitted seq=
1745165
2018-08-09T23:16:53.103795+08:00 MGDT-Tumbleweed kernel: [ 6305.852704] [drm] No hardware hang detected. Did some blocks stall?


Dmesg lines relative to amdgpu:

[    3.130759] [drm] amdgpu kernel modesetting enabled.
[    3.135770] fb: switching to amdgpudrmfb from EFI VGA
[    3.136106] amdgpu 0000:03:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff
[    3.136171] amdgpu 0000:03:00.0: VRAM: 8176M 0x000000F400000000 - 0x000000F5FEFFFFFF (8176M used)
[    3.136173] amdgpu 0000:03:00.0: GTT: 512M 0x000000F600000000 - 0x000000F61FFFFFFF
[    3.136494] [drm] amdgpu: 8176M of VRAM memory ready
[    3.136495] [drm] amdgpu: 8176M of GTT memory ready.
[    4.114469] fbcon: amdgpudrmfb (fb0) is primary device
[    4.141179] amdgpu 0000:03:00.0: fb0: amdgpudrmfb frame buffer device
[    4.164072] amdgpu 0000:03:00.0: ring 0(gfx) uses VM inv eng 4 on hub 0
[    4.164074] amdgpu 0000:03:00.0: ring 1(comp_1.0.0) uses VM inv eng 5 on hub 0
[    4.164075] amdgpu 0000:03:00.0: ring 2(comp_1.1.0) uses VM inv eng 6 on hub 0
[    4.164075] amdgpu 0000:03:00.0: ring 3(comp_1.2.0) uses VM inv eng 7 on hub 0
[    4.164076] amdgpu 0000:03:00.0: ring 4(comp_1.3.0) uses VM inv eng 8 on hub 0
[    4.164077] amdgpu 0000:03:00.0: ring 5(comp_1.0.1) uses VM inv eng 9 on hub 0
[    4.164078] amdgpu 0000:03:00.0: ring 6(comp_1.1.1) uses VM inv eng 10 on hub 0
[    4.164079] amdgpu 0000:03:00.0: ring 7(comp_1.2.1) uses VM inv eng 11 on hub 0
[    4.164079] amdgpu 0000:03:00.0: ring 8(comp_1.3.1) uses VM inv eng 12 on hub 0
[    4.164080] amdgpu 0000:03:00.0: ring 9(kiq_2.1.0) uses VM inv eng 13 on hub 0
[    4.164081] amdgpu 0000:03:00.0: ring 10(sdma0) uses VM inv eng 4 on hub 1
[    4.164082] amdgpu 0000:03:00.0: ring 11(sdma1) uses VM inv eng 5 on hub 1
[    4.164083] amdgpu 0000:03:00.0: ring 12(uvd) uses VM inv eng 6 on hub 1
[    4.164084] amdgpu 0000:03:00.0: ring 13(uvd_enc0) uses VM inv eng 7 on hub 1
[    4.164085] amdgpu 0000:03:00.0: ring 14(uvd_enc1) uses VM inv eng 8 on hub 1
[    4.164085] amdgpu 0000:03:00.0: ring 15(vce0) uses VM inv eng 9 on hub 1
[    4.164086] amdgpu 0000:03:00.0: ring 16(vce1) uses VM inv eng 10 on hub 1
[    4.164087] amdgpu 0000:03:00.0: ring 17(vce2) uses VM inv eng 11 on hub 1
[    4.164553] [drm] Initialized amdgpu 3.25.0 20150101 for 0000:03:00.0 on minor 0
Comment 6 Stefan Dirsch 2018-08-14 13:13:21 UTC
Ok. :-(
Comment 7 Mauro Gaspari 2018-08-28 01:31:53 UTC
Quick Update:

I updated Tumbleweed, unfortunately same issue persists.

OS: OpenSUSE tumbleweed x86_64 updated (2018 08 27)
Kernel: 4.18.0-1-default
Desktop Environment: KDE Plasma (x11)
OpenGL version string: 3.1 Mesa 18.1.6
GPU: AMD Radeon RX Vega 64 8GB 

I upgraded most hardware on my Tumbleweed desktop, short of the VEGA GPU. Same issue persists.
Replaced hardware:
Motherboard: ASUS ROG Strix x470 GAMING
CPU: Ryzen 2700-X
RAM: 4x 16GB Kingston HyperX 3200mhz

I had a look at https://bugs.freedesktop.org/buglist.cgi?component=DRM%2FAMDgpu&product=DRI
It looks there are many bug reports on AMDGPU freezing. Was this report already taken upstream or shall I file the bug @ freedesktop.org?
Comment 8 Stefan Dirsch 2018-08-28 09:23:42 UTC
Thanks. It would help to file such a bug upstream, yes.
Comment 9 Mauro Gaspari 2018-08-28 09:42:41 UTC
Upstream bug updated: https://bugs.freedesktop.org/show_bug.cgi?id=105317
Comment 10 Stefan Dirsch 2018-08-28 10:18:48 UTC
(In reply to Mauro Gaspari from comment #9)
> Upstream bug updated: https://bugs.freedesktop.org/show_bug.cgi?id=105317

Thanks!
Comment 11 Mauro Gaspari 2018-09-05 03:21:25 UTC
I spent some more time troubleshooting this issue. This is what I found out.

I installed steam and ran a few native games, no system freezes that I could replicate. I want to point out that before the bug was closed in April 2018 even native games were freezing the system.
The system freeze issue seem to happen only when running games via Wine since I reopened the bug. I went further on that and asked some friends that use macOS and run the same game, and I was very surprised to hear they are having the same issue.

So I went ahead and involved codeweavers on this. I shared this bug and the one I opened upstream. They are investigating and they said they can also replicate this system freeze.

I will update the bug tracker as I get more information.
Comment 12 Stefan Dirsch 2018-09-05 10:05:28 UTC
Thanks for the update. Oh, there is Wine on MacOS. Interesting!
Comment 15 Mauro Gaspari 2018-10-21 08:45:35 UTC
I made some progress. Tested a bit more on Arch and Ubuntu, and same issue happens there as well. Kernel 4.18.x combined to mesa above 18.0.5 causes the problem, on all distros i tested. As I am more familiar with Ubuntu, I Installed 18.10, kernel 4.18.0-10 I tried up to Mesa 18.2.2 available on various Xorg repos for ubuntu. Same issue perists.
Next step I enabled oibaf repositories that hold latest mesa from git. https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers
Followed instructions, upgraded system and rebooted. Mesa was updated to 18.3.0-devel, and the issue was resolved. 
I did not have much time to play but I left a Wine-based game running overnight and there was no crash, no hang, no freeze.

Is there any way to enable extra development repos on tumbleweed so I can test Mesa 18.3.x as well and compare results?

Thanks
Mauro
Comment 16 Stefan Dirsch 2018-10-21 20:49:51 UTC
There is X11:XOrg development repo for Mesa on build.opensuse.org, but there is no Mesa 18.3.0 yet. 18.2.3 is the latest available one. This 18.3.0-devel on Ubuuntu appears to be git master.
Comment 17 Michal Srb 2018-10-22 09:34:37 UTC
You identified that the fix is somewhere between Mesa-18.2.2 and current git master. That is great.

A shot in the dark: It could be fixed by d179312b "radv: add a workaround for a VGT hang with prim restart and strips". According to the description it fixes hangs with with some games using DXVK. By the way, my guess is that the reason why it now happens with some games under wine, but not with native games is that most games under wine use DirectX translated to Vulkan, while most native games still use OpenGL.

Could you try with Mesa from this OBS project?
https://build.opensuse.org/project/show/home:michalsrb:bug1090456:X11:XOrg
Comment 19 Mauro Gaspari 2018-10-22 13:04:58 UTC
Hello Michal and thanks for your help.

Good news first: I added the repo, installed new packages, rebooted. And it seems I managed to not break the system. No need to ask Snapper to come to my rescue this time :)

Bad news: No change so far

More details:
In this case, I am focusing on EVE online run through Crossover 18.0. and Playonlinux (tried both, same results).
This game was chosen because it is the one that had the easier to reproduce issue, as it happens pretty quickly. With Kernels 4.17.x and Mesa after 18.0.5, the game started freezing the system again, randomly during gameplay. With Kernels 4.18.x and any mesa prior to 18.3(Git Master) it gets even easier to track, because the game crashes on the launcher even before starting. I am adding here a screenshot of the launcher, and bug reports. 
On kernels 4.18.x and mesa 18.3 (Git Master) the launcher stops creating issues, game starts, and has no freezes. I tried on both DX9 and DX11 modes (with DXVK). DX9 mode is flawless, DX11 is slower and a bit buggier.

Additional details: Friends playing the same game on MacOS through wine reported same issues before, and told me that after latest MacOS upgrade in October2018, no freezes happen for them.

Error Trace from Crossover --------
0x10db5511: int	$3
Modules:
Module	Address			Debug info	Name (195 modules)
PE	  340000-  35a000	Deferred        qt5webchannel
PE	  360000-  3a8000	Deferred        qt5positioning
PE	  400000-  408000	Export          qtwebengineprocess
PE	  410000-  71e000	Deferred        qt5quick
PE	  720000-  c31000	Deferred        qt5gui
PE	  c40000-  d2e000	Deferred        msvcr120
PE	10000000-13594000	Export          qt5webenginecore
PE	64000000-6426e000	Deferred        qt5network
PE	66000000-662f6000	Deferred        qt5qml
PE	67000000-674cf000	Deferred        qt5core
PE	6a540000-6a774000	Deferred        d3d11
PE	6f400000-6f5c0000	Deferred        dxgi
ELF	7a800000-7a93b000	Deferred        opengl32<elf>
  \-PE	7a820000-7a93b000	\               opengl32
ELF	7b400000-7b7ed000	Deferred        kernel32<elf>
  \-PE	7b420000-7b7ed000	\               kernel32
ELF	7bc00000-7bd21000	Deferred        ntdll<elf>
  \-PE	7bc40000-7bd21000	\               ntdll
ELF	7c000000-7c003000	Deferred        <wine-loader>
ELF	7c149000-7c177000	Deferred        libpng12.so.0
ELF	7c177000-7c1c6000	Deferred        libvulkan.so.1
ELF	7c1f1000-7c215000	Deferred        libgpg-error.so.0
ELF	7c215000-7c2f8000	Deferred        libgcrypt.so.20
ELF	7c2f8000-7c317000	Deferred        liblz4.so.1
ELF	7c317000-7c350000	Deferred        liblzma.so.5
ELF	7c350000-7c400000	Deferred        libsystemd.so.0
ELF	7c405000-7c40b000	Deferred        libcap.so.2
ELF	7c40b000-7c499000	Deferred        libpcre.so.1
ELF	7c499000-7c4c7000	Deferred        libselinux.so.1
ELF	7c4c7000-7c4cd000	Deferred        libkeyutils.so.1
ELF	7c4cd000-7c52d000	Deferred        libdbus-1.so.3
ELF	7c52d000-7c53c000	Deferred        libkrb5support.so.0
ELF	7c53c000-7c541000	Deferred        libcom_err.so.2
ELF	7c541000-7c577000	Deferred        libk5crypto.so.3
ELF	7c577000-7c656000	Deferred        libkrb5.so.3
ELF	7c656000-7c66b000	Deferred        libavahi-client.so.3
ELF	7c66b000-7c67a000	Deferred        libavahi-common.so.3
ELF	7c67a000-7c6ce000	Deferred        libgssapi_krb5.so.2
ELF	7c6ce000-7c781000	Deferred        libcups.so.2
ELF	7c781000-7c7fa000	Deferred        wineps<elf>
  \-PE	7c7a0000-7c7fa000	\               wineps
ELF	7c7fa000-7c801000	Deferred        libxfixes.so.3
ELF	7c801000-7c80d000	Deferred        libxcursor.so.1
ELF	7c80d000-7c821000	Deferred        libxi.so.6
ELF	7c821000-7c825000	Deferred        libxcomposite.so.1
ELF	7c825000-7c834000	Deferred        libxrandr.so.2
ELF	7c834000-7c840000	Deferred        libxrender.so.1
ELF	7c840000-7c847000	Deferred        libxxf86vm.so.1
ELF	7c847000-7c84b000	Deferred        libxinerama.so.1
ELF	7c84b000-7c850000	Deferred        libxau.so.6
ELF	7c850000-7c87f000	Deferred        libxcb.so.1
ELF	7c87f000-7c9d2000	Deferred        libx11.so.6
ELF	7c9d2000-7c9e8000	Deferred        libxext.so.6
ELF	7c9e8000-7ca78000	Deferred        winex11<elf>
  \-PE	7c9f0000-7ca78000	\               winex11
ELF	7ca78000-7cb07000	Deferred        libgmp.so.10
ELF	7cb07000-7cb3f000	Deferred        libhogweed.so.4
ELF	7cb3f000-7cb7d000	Deferred        libnettle.so.6
ELF	7cb7d000-7cb92000	Deferred        libtasn1.so.6
ELF	7cb92000-7cd16000	Deferred        libunistring.so.2
ELF	7cd16000-7cd35000	Deferred        libidn2.so.0
ELF	7cd35000-7ce83000	Deferred        libp11-kit.so.0
ELF	7ce83000-7d056000	Deferred        libgnutls.so.30
ELF	7d068000-7d081000	Deferred        kerberos<elf>
  \-PE	7d070000-7d081000	\               kerberos
ELF	7d2f0000-7d32b000	Deferred        libexpat.so.1
ELF	7d32b000-7d378000	Deferred        libfontconfig.so.1
ELF	7d378000-7d3ba000	Deferred        libpng16.so.16
ELF	7d3ba000-7d3d4000	Deferred        libbz2.so.1
ELF	7d3d4000-7d485000	Deferred        libfreetype.so.6
ELF	7d486000-7d4a4000	Deferred        concrt140<elf>
  \-PE	7d490000-7d4a4000	\               concrt140
ELF	7d4b0000-7d4c6000	Deferred        dxva2<elf>
  \-PE	7d4c0000-7d4c6000	\               dxva2
ELF	7d4c6000-7d61f000	Deferred        wined3d<elf>
  \-PE	7d4e0000-7d61f000	\               wined3d
ELF	7d61f000-7d65e000	Deferred        d3d9<elf>
  \-PE	7d630000-7d65e000	\               d3d9
ELF	7d65e000-7d676000	Deferred        hid<elf>
  \-PE	7d660000-7d676000	\               hid
ELF	7d676000-7d72d000	Deferred        msvcrt<elf>
  \-PE	7d690000-7d72d000	\               msvcrt
ELF	7d72d000-7d766000	Deferred        winevulkan<elf>
  \-PE	7d740000-7d766000	\               winevulkan
ELF	7d766000-7d77d000	Deferred        vulkan-1<elf>
  \-PE	7d770000-7d77d000	\               vulkan-1
ELF	7d77d000-7d793000	Deferred        dwmapi<elf>
  \-PE	7d780000-7d793000	\               dwmapi
ELF	7d793000-7d7fc000	Deferred        dwrite<elf>
  \-PE	7d7a0000-7d7fc000	\               dwrite
ELF	7d7fc000-7d819000	Deferred        jsproxy<elf>
  \-PE	7d800000-7d819000	\               jsproxy
ELF	7d819000-7d858000	Deferred        winhttp<elf>
  \-PE	7d820000-7d858000	\               winhttp
ELF	7d858000-7d8d2000	Deferred        wininet<elf>
  \-PE	7d860000-7d8d2000	\               wininet
ELF	7d8d2000-7d96e000	Deferred        urlmon<elf>
  \-PE	7d8e0000-7d96e000	\               urlmon
ELF	7d96e000-7d9a3000	Deferred        secur32<elf>
  \-PE	7d970000-7d9a3000	\               secur32
ELF	7d9a3000-7dada000	Deferred        oleaut32<elf>
  \-PE	7d9c0000-7dada000	\               oleaut32
ELF	7dada000-7daf3000	Deferred        libz.so.1
ELF	7daf6000-7db0b000	Deferred        dhcpcsvc<elf>
  \-PE	7db00000-7db0b000	\               dhcpcsvc
ELF	7db0b000-7db1e000	Deferred        psapi<elf>
  \-PE	7db10000-7db1e000	\               psapi
ELF	7db1e000-7db82000	Deferred        dbghelp<elf>
  \-PE	7db30000-7db82000	\               dbghelp
ELF	7db82000-7dbc2000	Deferred        winspool<elf>
  \-PE	7db90000-7dbc2000	\               winspool
ELF	7dbc2000-7dc07000	Deferred        usp10<elf>
  \-PE	7dbd0000-7dc07000	\               usp10
ELF	7dc07000-7dd42000	Deferred        comctl32<elf>
  \-PE	7dc10000-7dd42000	\               comctl32
ELF	7dd42000-7de32000	Deferred        comdlg32<elf>
  \-PE	7dd50000-7de32000	\               comdlg32
ELF	7de32000-7defe000	Deferred        crypt32<elf>
  \-PE	7de40000-7defe000	\               crypt32
ELF	7df20000-7df29000	Deferred        libffi.so.7
ELF	7df30000-7df53000	Deferred        imm32<elf>
  \-PE	7df40000-7df53000	\               imm32
ELF	7df53000-7df74000	Deferred        bcrypt<elf>
  \-PE	7df60000-7df74000	\               bcrypt
ELF	7df74000-7df93000	Deferred        dnsapi<elf>
  \-PE	7df80000-7df93000	\               dnsapi
ELF	7df93000-7dfa6000	Deferred        api-ms-win-crt-locale-l1-1-0<elf>
  \-PE	7dfa0000-7dfa6000	\               api-ms-win-crt-locale-l1-1-0
ELF	7dfa6000-7dfb9000	Deferred        api-ms-win-crt-filesystem-l1-1-0<elf>
  \-PE	7dfb0000-7dfb9000	\               api-ms-win-crt-filesystem-l1-1-0
ELF	7dfb9000-7dfce000	Deferred        api-ms-win-crt-convert-l1-1-0<elf>
  \-PE	7dfc0000-7dfce000	\               api-ms-win-crt-convert-l1-1-0
ELF	7dfce000-7dfe1000	Deferred        api-ms-win-crt-time-l1-1-0<elf>
  \-PE	7dfd0000-7dfe1000	\               api-ms-win-crt-time-l1-1-0
ELF	7dfe1000-7dff4000	Deferred        api-ms-win-crt-utility-l1-1-0<elf>
  \-PE	7dff0000-7dff4000	\               api-ms-win-crt-utility-l1-1-0
ELF	7dff4000-7e009000	Deferred        api-ms-win-crt-string-l1-1-0<elf>
  \-PE	7e000000-7e009000	\               api-ms-win-crt-string-l1-1-0
ELF	7e009000-7e021000	Deferred        api-ms-win-crt-math-l1-1-0<elf>
  \-PE	7e010000-7e021000	\               api-ms-win-crt-math-l1-1-0
ELF	7e021000-7e035000	Deferred        api-ms-win-crt-stdio-l1-1-0<elf>
  \-PE	7e030000-7e035000	\               api-ms-win-crt-stdio-l1-1-0
ELF	7e035000-7e048000	Deferred        api-ms-win-crt-environment-l1-1-0<elf>
  \-PE	7e040000-7e048000	\               api-ms-win-crt-environment-l1-1-0
ELF	7e048000-7e05b000	Deferred        api-ms-win-crt-heap-l1-1-0<elf>
  \-PE	7e050000-7e05b000	\               api-ms-win-crt-heap-l1-1-0
ELF	7e05b000-7e06f000	Deferred        api-ms-win-crt-runtime-l1-1-0<elf>
  \-PE	7e060000-7e06f000	\               api-ms-win-crt-runtime-l1-1-0
ELF	7e06f000-7e084000	Deferred        vcruntime140<elf>
  \-PE	7e070000-7e084000	\               vcruntime140
ELF	7e084000-7e17c000	Deferred        ucrtbase<elf>
  \-PE	7e0a0000-7e17c000	\               ucrtbase
ELF	7e17c000-7e29e000	Deferred        msvcp140<elf>
  \-PE	7e1c0000-7e29e000	\               msvcp140
ELF	7e29e000-7e356000	Deferred        winmm<elf>
  \-PE	7e2b0000-7e356000	\               winmm
ELF	7e356000-7e3ca000	Deferred        shlwapi<elf>
  \-PE	7e360000-7e3ca000	\               shlwapi
ELF	7e3ca000-7e6a4000	Deferred        shell32<elf>
  \-PE	7e3e0000-7e6a4000	\               shell32
ELF	7e6a4000-7e6bb000	Deferred        userenv<elf>
  \-PE	7e6b0000-7e6bb000	\               userenv
ELF	7e6bb000-7e6f8000	Deferred        ws2_32<elf>
  \-PE	7e6c0000-7e6f8000	\               ws2_32
ELF	7e6f8000-7e720000	Deferred        iphlpapi<elf>
  \-PE	7e700000-7e720000	\               iphlpapi
ELF	7e720000-7e74f000	Deferred        netapi32<elf>
  \-PE	7e730000-7e74f000	\               netapi32
ELF	7e74f000-7e776000	Deferred        mpr<elf>
  \-PE	7e760000-7e776000	\               mpr
ELF	7e776000-7e7f5000	Deferred        rpcrt4<elf>
  \-PE	7e780000-7e7f5000	\               rpcrt4
ELF	7e7f5000-7e94a000	Deferred        ole32<elf>
  \-PE	7e810000-7e94a000	\               ole32
ELF	7e94a000-7e963000	Deferred        version<elf>
  \-PE	7e950000-7e963000	\               version
ELF	7e963000-7e9de000	Deferred        advapi32<elf>
  \-PE	7e970000-7e9de000	\               advapi32
ELF	7e9de000-7eb0c000	Deferred        gdi32<elf>
  \-PE	7e9f0000-7eb0c000	\               gdi32
ELF	7eb0c000-7ed10000	Deferred        user32<elf>
  \-PE	7eb20000-7ed10000	\               user32
ELF	7eec6000-7efcb000	Deferred        libm.so.6
ELF	7efcb000-7efd5000	Deferred        librt.so.1
ELF	7efd5000-7efed000	Deferred        libresolv.so.2
ELF	7efed000-7f000000	Deferred        wow64cpu<elf>
  \-PE	7eff0000-7f000000	\               wow64cpu
ELF	f7af5000-f7afa000	Deferred        libdl.so.2
ELF	f7afa000-f7cdb000	Deferred        libc.so.6
ELF	f7cdb000-f7cfa000	Deferred        libpthread.so.0
ELF	f7d09000-f7d20000	Deferred        shcore<elf>
  \-PE	f7d10000-f7d20000	\               shcore
ELF	f7d25000-f7edd000	Dwarf           libwine.so.1
ELF	f7edf000-f7f08000	Deferred        ld-linux.so.2
ELF	f7f0b000-f7f0d000	Deferred        [vdso].so
Threads:
process  tid      prio (all id:s are in hex)
0000000c services.exe
	00000021    0
	0000001c    0
	00000016    0
	00000011    0
	0000000e    0
	0000000d    0
0000000f winedevice.exe
	00000019    0
	00000015    0
	00000014    0
	00000010    0
0000001a plugplay.exe
	0000001e    0
	0000001d    0
	0000001b    0
0000001f winedevice.exe
	00000026    0
	00000023    0
	00000022    0
	00000020    0
00000027 explorer.exe
	0000002b    0
	0000002a    0
	00000029    0
	00000028    0
0000009c winewrapper.exe
	0000009d    0
0000009e evelauncher.exe
	00000106   15
	00000103    0
	00000102    0
	00000101    0
	000000ff    0
	000000f1    0
	000000ef    0
	000000ee    0
	000000ed    0
	000000ea    0
	000000d4    0
	000000d3    0
	000000d2    0
	000000d1    0
	000000d0    0
	000000cf    0
	000000ce    0
	000000cd    0
	000000cc    0
	000000cb    0
	000000ca    0
	000000c9   -2
	000000c8    0
	000000c7    0
	000000c6    0
	000000c5    0
	000000c4    0
	000000c3    0
	000000c2    0
	000000c1    0
	000000c0    0
	000000bf    0
	000000be   -2
	000000bd   -2
	000000bc   -2
	000000bb    0
	000000ba    0
	000000b9    0
	000000b8    0
	000000b7    0
	000000b6    0
	000000b5    0
	000000b4    0
	000000b3    0
	000000b2    0
	000000b1    0
	000000b0    0
	000000af    0
	000000ae    0
	000000ad    0
	000000ac    0
	000000ab    0
	000000aa    0
	000000a9    0
	000000a8    0
	000000a7    0
	000000a6    0
	000000a5    0
	000000a4    0
	000000a3    0
	000000a2    0
	000000a1    0
	000000a0    0
	0000009f    0
000000d6 (D) C:\EVE\Launcher\QtWebEngineProcess.exe
	000000f0    0
	000000eb    0
	000000e8   -2
	000000e7    0
	000000e6    0
	000000e5    0
	000000e4    0
	000000e3    0
	000000e2    0
	000000e1    0
	000000e0    0
	000000df    0
	000000de    0
	000000dd    0
	000000dc    0
	000000db   -2
	000000da   -2
	000000d9    0
	000000d8    0
	000000d7    0 <==
System information:
    Wine build: wine-3.14-7989-gc984b52
    Platform: i386
    Version: Windows XP
    Host system: Linux
    Host version: 4.18.13-1-default
Comment 20 Mauro Gaspari 2018-10-22 13:08:05 UTC
Created attachment 786716 [details]
EVElauncher-crash
Comment 21 Mauro Gaspari 2018-10-28 18:36:42 UTC
I have been doing a few more tests on other distributions to compare results with kernels and mesa versions. I used KDE Plasma in all my tests: Kubuntu 18.04, Kubuntu 18.10, Arch, Arch testing.

Kubuntu 18.04. Kernel 4.15.x, mesa 18.0.5 - No issues. As I previously stated, issues I reported in this bug, seem to start after the Ubuntu LTS kernels and mesa come to play.

Kubuntu 18.10 Kernel 4.18.10 mesa 18.2.2 - Same issue as on tumbleweed. Launcher does not render correctly. This is solved completely by adding the oibaf repository and letting it upgrade mesa to git-master. After that change, I have no crashes and launcher works fine.

Arch Kernel 4.18.16 mesa 18.2.3 - Launcher renders correctly, game starts, but freezes randomly per original bug. However, interestingly, when the game freezes, instead of locking the whole OS, now it only freezes the game process. So i can kill it, and keep using my desktop. This is some nice progress.

Arch testing Kernel 4.19.0 mesa 18.2.3 - No issues with launcher, game starts fine, and works without freezes.

I hope this helps.
Mauro
Comment 22 Mauro Gaspari 2018-11-27 08:09:31 UTC
After more testing, I have further updates, good news and bad news.

Bad news:
It seems with AMD the road is still a bit bumpy. Drivers are improving but still not perfect. I have been testing Mesa from git and even for newer versions, some work well some have regressions.

Good news:
Things are getting better. First of all it has been months since I had a system freeze on native games. Regarding Wine based games, with Kernels 4.19.x on both Arch and Tumbleweed, even if mesa locks, now it no longer freezes the whole system. It only freezes the specific app/game, then I can easily kill it and avoid a cold reboot of the whole system. I think this is already a great improvement.


Further hacking:
I have been tweaking and hacking at steam with proton, and it looks we will have a better life ahead. For now, official proton support is not covering many games. I forced it and enabled on all games, then started tweaking settings. Wine version included with steam and proton seems to be wine-staging. So I can go in wine settings for each specific game, edit wine settings and enable either wine-nine or CSMT to improve stability and framerates. Soon I believe steam will use Wine 3.20 which seems to be bringing great improvements.

Ticket status:
I believe this ticket can be closed. Native apps no longer freeze system. And even wine based apps now only freeze the specific app.
Wine-based games freezes are caused by a combination of wine version/settings, mesa, and kernel, therefore the best place to report those I believe will be in freedesktop and winehq.
Comment 23 Stefan Dirsch 2019-01-26 19:54:17 UTC
Oops. Missed to close this bug ...