Bug 1090396 - kubelet fails get system container, cgroup stats and container info
kubelet fails get system container, cgroup stats and container info
Status: RESOLVED DUPLICATE of bug 1086185
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Containers
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Containers Team
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-20 14:43 UTC by Panagiotis Georgiadis
Modified: 2018-04-20 15:31 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Panagiotis Georgiadis 2018-04-20 14:43:57 UTC
systemd start kubelet service like this:

> /usr/bin/hyperkube kubelet --logtostderr=true --v=2 --address=127.0.0.1 --hostname-override=127.0.0.1 --allow-privileged=false --pod-manifest-path=/etc/kubernetes/manifests

at some point you will encounter:

> E0420 16:37:35.274138    7195 summary.go:92] Failed to get system container stats for "/user.slice/user-1000.slice/user@1000.service/gnome-terminal-server.service": failed to get cgroup stats for "/user.slice/user-1000.slice/user@1000.service/gnome-terminal-server.service": failed to get container info for "/user.slice/user-1000.slice/user@1000.service/gnome-terminal-server.service": unknown container "/user.slice/user-1000.slice/user@1000.service/gnome-terminal-server.service"

There is a proposal fix for this at: https://github.com/kubernetes/kubernetes/issues/56850

Edit '/etc/kubernetes/kubelet' and add the following line:

> KUBELET_CGROUP_ARGS="--cgroup-driver=cgroupfs --runtime-cgroups=/systemd/system.slice --kubelet-cgroups=/systemd/system.slice"

Edit the '/usr/lib/systemd/system/kubelet.service' file and modify the 'ExecStart=' of the [SERVICE] section by adding:

>             $KUBELET_ARGS \
>             $KUBELET_CGROUP_ARGS

Then reload systemd and restart the kubelet service:

> systemctl daemon-reload
> systemctl restart kubelet

-> There will be no such error, but the results of the container stats:

> I0420 16:41:48.557436    8350 kubelet_node_status.go:273] Setting node annotation to enable volume controller attach/detach
> I0420 16:41:48.558382    8350 kubelet_node_status.go:431] Recording NodeHasSufficientDisk event message for node 127.0.0.1
> I0420 16:41:48.558396    8350 kubelet_node_status.go:431] Recording NodeHasSufficientMemory event message for node 127.0.0.1
> I0420 16:41:48.558405    8350 kubelet_node_status.go:431] Recording NodeHasNoDiskPressure event message for node 127.0.0.1
> I0420 16:41:48.626475    8350 kubelet.go:1851] SyncLoop (ADD, "file"): "
Comment 1 Flavio Castelli 2018-04-20 15:31:00 UTC
This overlaps a lot with https://bugzilla.suse.com/show_bug.cgi?id=1086185

I'll treat that as duplicate of it

*** This bug has been marked as a duplicate of bug 1086185 ***