Bug 1090386 - cross-arm-linux-gnueabi-gcc depends on obsolete libmpfr.so.4
cross-arm-linux-gnueabi-gcc depends on obsolete libmpfr.so.4
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
x86-64 openSUSE Factory
: P5 - None : Major (vote)
: ---
Assigned To: Andrew Wafaa
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-20 13:44 UTC by Marcelo Jimenez
Modified: 2020-07-27 07:23 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcelo Jimenez 2018-04-20 13:44:02 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.117 Safari/537.36
Build Identifier: 

cross-arm-linux-gnueabi-gcc depends on obsolete libmpfr.so.4 which is no longer on the distribution, so the package is currently broken. It should depend on libmpfr.so.6 or better, be upgraded to gcc7 or gcc8.

Reproducible: Always

Steps to Reproduce:
1.Create hello.c
2.run $ arm-linux-gnueabi-gcc -march=armv5 hello.c -o hello
3.
Actual Results:  
/opt/cross/libexec/gcc/arm-linux-gnueabi/4.9.3/cc1: error while loading shared libraries: libmpfr.so.4: cannot open shared object file: No such file or directory


Expected Results:  
A successful error free compilation.
Comment 1 Andrew Wafaa 2020-07-27 07:23:37 UTC
My packages are links to https://build.opensuse.org/package/show/home:duwe:crosstools/cross-arm-linux-gnueabi-binutils

I've not touched these for over 7 years, sorry.