Bug 1090319 - pattern:gnome-20180321-lp150.1.1.x86_64 requires patterns-gnome-gnome, but this requirement cannot be provided
pattern:gnome-20180321-lp150.1.1.x86_64 requires patterns-gnome-gnome, but th...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Patterns
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dominique Leuenberger
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-20 06:33 UTC by Oliver Kurz
Modified: 2018-05-15 12:38 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Kurz 2018-04-20 06:33:30 UTC
## Observation

```
# zypper in -t pattern gnome kde non_oss xfce 
Loading repository data...
Warning: Repository 'openSUSE-Leap-15.0-Update' appears to be outdated. Consider using a different mirror or server.
Warning: Repository 'openSUSE-Leap-15.0-Update-Non-Oss' appears to be outdated. Consider using a different mirror or server.
Reading installed packages...
Resolving package dependencies...

Problem: pattern:gnome-20180321-lp150.1.1.x86_64 requires patterns-gnome-gnome, but this requirement cannot be provided
  uninstallable providers: patterns-gnome-gnome-20180321-lp150.1.1.x86_64[openSUSE-Leap-15.0-1]
                   patterns-gnome-gnome-20180321-lp150.1.1.x86_64[repo-oss]
 Solution 1: Following actions will be done:
  do not install pattern:gnome-20180321-lp150.1.1.x86_64
  do not install pattern:kde-20170319-lp150.7.1.noarch
 Solution 2: deinstallation of patterns-yast-x11_yast-20180409-lp150.1.1.x86_64
 Solution 3: break pattern:gnome-20180321-lp150.1.1.x86_64 by ignoring some of its dependencies
```


## Problem

Solution 2 fixes it, so why do I need to remove "patterns-yast-x11_yast"?
Comment 2 Swamp Workflow Management 2018-04-26 16:20:05 UTC
This is an autogenerated message for OBS integration:
This bug (1090319) was mentioned in
https://build.opensuse.org/request/show/601637 15.0 / patterns-yast
Comment 3 Ludwig Nussel 2018-04-27 11:58:19 UTC
fixed for leap. the same is still in TW though
Comment 4 Dominique Leuenberger 2018-04-27 12:06:26 UTC
(In reply to Ludwig Nussel from comment #3)
> fixed for leap. the same is still in TW though

grmbl - makes one wonder why there was a conflict to start with.

Any reason you dropped also the supplements in sr#601637 ?
Comment 5 Dominique Leuenberger 2018-04-27 12:06:56 UTC
(In reply to Dominique Leuenberger from comment #4)
> (In reply to Ludwig Nussel from comment #3)
> > fixed for leap. the same is still in TW though
> 
> grmbl - makes one wonder why there was a conflict to start with.
> 
> Any reason you dropped also the supplements in sr#601637 ?

I mean instead of adjusting the names - as patterns-openSUSE is obviously oudated
Comment 6 Ludwig Nussel 2018-04-27 12:10:06 UTC
x11_yast is already recomended by x11_enhanced
Comment 7 Dominique Leuenberger 2018-04-27 12:18:02 UTC
https://github.com/yast/patterns-yast/pull/14
Comment 8 Dominique Leuenberger 2018-05-15 12:38:03 UTC
(In reply to Dominique Leuenberger from comment #7)
> https://github.com/yast/patterns-yast/pull/14

Merged