Bug 1089818 - qbittorrent: Fails to build with Boost 1.67.0 and libtorrent-rasterbar 1.1.6
qbittorrent: Fails to build with Boost 1.67.0 and libtorrent-rasterbar 1.1.6
Status: RESOLVED DUPLICATE of bug 1089812
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Network
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Alexei Sorokin
E-mail List
:
Depends on:
Blocks: 1089801
  Show dependency treegraph
 
Reported: 2018-04-17 08:48 UTC by Adam Majer
Modified: 2018-04-17 11:39 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Majer 2018-04-17 08:48:51 UTC
New Boost library has been released and unfortunately this package fails to build with it. The new boost library is already submitted to devel:libraries:c_c++/boost and will be submitted to openSUSE:Factory shortly.

https://build.opensuse.org/package/live_build_log/home:adamm:boost_test/qbittorrent/openSUSE_Tumbleweed/x86_64

> [   78s] /usr/include/libtorrent/ip_filter.hpp: In member function 'void libtorrent::detail::filter_impl<Addr>::add_rule(Addr, Addr, int)':
> [   78s] /usr/include/libtorrent/ip_filter.hpp:168:41: error: 'prior' is not a member of 'boost'
> [   78s]     boost::uint32_t last_access = boost::prior(j)->access;
> [   78s]                                          ^~~~~
> [   78s] /usr/include/libtorrent/ip_filter.hpp:174:50: error: 'prior' is not a member of 'boost'


The cause of this is that boost::prior and boost::next have been moved. From Boost release notes,

Breaking change: <boost/utility.hpp> header no longer includes boost::next and boost::prior as they have been moved to the iterator module. Instead include <boost/next_prior.hpp>. Other uses of <boost/utility.hpp> are discouraged, it's better to use the header for the specific functionality instead.
Comment 1 Luigi Baldoni 2018-04-17 10:29:16 UTC
The problem actually appears to originate from libtorrent-rasterbar. Patching it.
Comment 2 Alexei Sorokin 2018-04-17 11:39:21 UTC
I'll just mark this as duplicate.

*** This bug has been marked as a duplicate of bug 1089812 ***