Bug 1089815 - python-espressopp: Fails to build with Boost 1.67.0
python-espressopp: Fails to build with Boost 1.67.0
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Christoph Junghans
E-mail List
:
Depends on:
Blocks: 1089801
  Show dependency treegraph
 
Reported: 2018-04-17 08:42 UTC by Adam Majer
Modified: 2018-08-16 13:36 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Majer 2018-04-17 08:42:56 UTC
New Boost library has been released and unfortunately this package fails to build with it. The new boost library is already submitted to devel:libraries:c_c++/boost and will be submitted to openSUSE:Factory shortly.

https://build.opensuse.org/package/live_build_log/home:adamm:boost_test/python-espressopp/openSUSE_Tumbleweed/x86_64


> [ 1657s] /home/abuild/rpmbuild/BUILD/espressopp-1.9.5/src/integrator/Adress.cpp:459:76:   required from here
> [ 1657s] /usr/include/boost/serialization/access.hpp:116:11: error: 'class std::vector<espressopp::Real3D*>' has no member named 'serialize'
> [ 1657s]          t.serialize(ar, file_version);
> [ 1657s]          ~~^~~~~~~~~

The cause is likely a missing header include.
Comment 1 Christoph Junghans 2018-04-29 19:05:56 UTC
Reported upstream
Comment 2 Christoph Junghans 2018-07-17 18:30:03 UTC
https://build.opensuse.org/request/show/623506
Comment 3 Swamp Workflow Management 2018-07-17 19:10:06 UTC
This is an autogenerated message for OBS integration:
This bug (1089815) was mentioned in
https://build.opensuse.org/request/show/623508 Factory / python-espressopp
Comment 4 Adam Majer 2018-08-16 13:36:55 UTC
Fixed in Factory. Closing.