Bug 1089812 - libtorrent-rasterbar: Fails to build with Boost 1.67.0
libtorrent-rasterbar: Fails to build with Boost 1.67.0
Status: RESOLVED FIXED
: 1089818 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Alexei Sorokin
E-mail List
:
Depends on:
Blocks: 1089801
  Show dependency treegraph
 
Reported: 2018-04-17 08:35 UTC by Adam Majer
Modified: 2018-05-23 09:54 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Majer 2018-04-17 08:35:29 UTC
New Boost library has been released and unfortunately this package fails to build with it. The new boost library is already submitted to devel:libraries:c_c++/boost and will be submitted to openSUSE:Factory shortly.

https://build.opensuse.org/package/live_build_log/home:adamm:boost_test/libtorrent-rasterbar/openSUSE_Tumbleweed/x86_64

> [  117s] ../../include/libtorrent/ip_filter.hpp: In member function 'void libtorrent::detail::filter_impl<Addr>::add_rule(Addr, Addr, int)':
> [  117s] ../../include/libtorrent/ip_filter.hpp:168:41: error: 'prior' is not a member of 'boost'
> [  117s]     boost::uint32_t last_access = boost::prior(j)->access;
> [  117s]                                          ^~~~~
> [  117s] ../../include/libtorrent/ip_filter.hpp:174:50: error: 'prior' is not a member of 'boost'

The cause of this is that boost::prior and boost::next have been moved. From Boost release notes,

Breaking change: <boost/utility.hpp> header no longer includes boost::next and boost::prior as they have been moved to the iterator module. Instead include <boost/next_prior.hpp>. Other uses of <boost/utility.hpp> are discouraged, it's better to use the header for the specific functionality instead.
Comment 1 Alexei Sorokin 2018-04-17 11:39:21 UTC
*** Bug 1089818 has been marked as a duplicate of this bug. ***
Comment 2 Alexei Sorokin 2018-04-17 11:40:06 UTC
I sent https://build.opensuse.org/request/show/597444, should take care of that.
Comment 3 Adam Majer 2018-05-23 09:54:24 UTC
Fixed in Factory. Closing.