Bug 1089810 - leechcraft: Fails to build with Boost 1.67.0
leechcraft: Fails to build with Boost 1.67.0
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dmitriy Perlow
E-mail List
:
Depends on:
Blocks: 1089801
  Show dependency treegraph
 
Reported: 2018-04-17 08:29 UTC by Adam Majer
Modified: 2018-05-18 16:06 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Majer 2018-04-17 08:29:46 UTC
New Boost library has been released and unfortunately this package fails to build with it. The new boost library is already submitted to devel:libraries:c_c++/boost and will be submitted to openSUSE:Factory shortly.

https://build.opensuse.org/package/live_build_log/home:adamm:boost_test/leechcraft/openSUSE_Tumbleweed/x86_64

> [  358s] In file included from /home/abuild/rpmbuild/BUILD/leechcraft-0.6.70-10870-g558588d6ec/src/plugins/bittorrent/core.cpp:68:0:
> [  358s] /usr/include/libtorrent/ip_filter.hpp: In member function 'void libtorrent::detail::filter_impl<Addr>::add_rule(Addr, Addr, int)':
> [  358s] /usr/include/libtorrent/ip_filter.hpp:168:41: error: 'prior' is not a member of 'boost'
> [  358s]     boost::uint32_t last_access = boost::prior(j)->access;
> [  358s]                                          ^~~~~

The cause of this is that boost::prior and boost::next have been moved. From Boost release notes,

Breaking change: <boost/utility.hpp> header no longer includes boost::next and boost::prior as they have been moved to the iterator module. Instead include <boost/next_prior.hpp>. Other uses of <boost/utility.hpp> are discouraged, it's better to use the header for the specific functionality instead.
Comment 1 Dmitriy Perlow 2018-04-17 12:15:18 UTC
Thanks!
Comment 2 Dmitriy Perlow 2018-04-17 15:52:44 UTC
Leechcraft developer uses Gentoo that unfortunately doesn't provide boost 1.67 just now so it will take some time to resolve the issue.
Comment 3 Adam Majer 2018-05-18 11:25:09 UTC
Seems this is now fixed.
Comment 4 Dmitriy Perlow 2018-05-18 16:06:36 UTC
Seems to be rasterbar's libtorrent issue.