Bug 1089808 - incinga2: Fails to build with Boost 1.67.0
incinga2: Fails to build with Boost 1.67.0
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Tim Hardeck
E-mail List
:
Depends on:
Blocks: 1089801
  Show dependency treegraph
 
Reported: 2018-04-17 08:25 UTC by Adam Majer
Modified: 2018-07-31 15:30 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Majer 2018-04-17 08:25:00 UTC
New Boost library has been released and unfortunately this package fails to build with it. The new boost library is already submitted to devel:libraries:c_c++/boost and will be submitted to openSUSE:Factory shortly.

https://build.opensuse.org/package/live_build_log/home:adamm:boost_test/icinga2/openSUSE_Tumbleweed/x86_64

> [   95s] /home/abuild/rpmbuild/BUILD/icinga2-2.8.2/lib/base/timer.cpp: In static member function 'static void icinga::Timer::TimerThreadProc()':
> [   95s] /home/abuild/rpmbuild/BUILD/icinga2-2.8.2/lib/base/timer.cpp:269:74: error: no matching function for call to 'boost::date_time::subsecond_duration<boost::posix_time::time_duration, 1000>::subsecond_duration(double)'
> [   95s]     l_TimerCV.timed_wait(lock, boost::posix_time::milliseconds(wait * 1000));
> [   95s]                                                                           ^

The cause of this is change in Boost:DateTime that no longer accepts non-integer types. In the past, these types were implicitly cast down to integer values. Now this requires explicit cast.

https://svn.boost.org/trac10/ticket/11168
Comment 1 Tim Hardeck 2018-04-17 09:38:09 UTC
Many thanks Adam for the detailed report. I have forward the issue upstream: https://github.com/Icinga/icinga2/issues/6232
Comment 2 Tim Hardeck 2018-04-17 12:12:51 UTC
I have back ported the upstream fix, so building should be possible now if you upgrade you test package from Factory.
Comment 3 Swamp Workflow Management 2018-04-17 13:10:05 UTC
This is an autogenerated message for OBS integration:
This bug (1089808) was mentioned in
https://build.opensuse.org/request/show/597478 Factory / icinga2
Comment 4 Adam Majer 2018-04-17 14:11:33 UTC
Yes, builds fine with new boost. Thank you.
Comment 5 Swamp Workflow Management 2018-07-20 17:00:33 UTC
This is an autogenerated message for OBS integration:
This bug (1089808) was mentioned in
https://build.opensuse.org/request/show/624310 Backports:SLE-12 / icinga2
Comment 6 Swamp Workflow Management 2018-07-31 15:30:32 UTC
This is an autogenerated message for OBS integration:
This bug (1089808) was mentioned in
https://build.opensuse.org/request/show/626737 Backports:SLE-12 / icinga2