Bug 1089806 - gnuradio: Fails to build with Boost 1.67.0
gnuradio: Fails to build with Boost 1.67.0
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Wojciech Kazubski
E-mail List
:
Depends on:
Blocks: 1089801
  Show dependency treegraph
 
Reported: 2018-04-17 08:14 UTC by Adam Majer
Modified: 2018-05-30 09:37 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Majer 2018-04-17 08:14:38 UTC
New Boost library has been released and unfortunately this package fails to build with it. The new boost library is already submitted to devel:libraries:c_c++/boost and will be submitted to openSUSE:Factory shortly.

https://build.opensuse.org/package/live_build_log/home:adamm:boost_test/gnuradio/openSUSE_Tumbleweed/x86_64

> [ 1645s] /home/abuild/rpmbuild/BUILD/gnuradio-3.7.11/gr-blocks/lib/message_strobe_impl.cc:93:78: error: no matching function for call to 'boost::date_time::subsecond_duration<boost::posix_time::time_duration, 1000>::subsecond_duration(float&)'
> [ 1645s]          boost::this_thread::sleep(boost::posix_time::milliseconds(d_period_ms));
> [ 1645s]                                                                               ^

The cause of this is change in Boost:DateTime that no longer accepts non-integer types. In the past, these types were implicitly cast down to integer values. Now this requires explicit cast.

https://svn.boost.org/trac10/ticket/11168
Comment 1 Adam Majer 2018-05-30 09:37:59 UTC
Fix submitted to Factory. Closing.