Bug 1089764 - openSUSE Tumbleweed: AARCH64: CONFIG_NR_CPUS should be set to 256
openSUSE Tumbleweed: AARCH64: CONFIG_NR_CPUS should be set to 256
Status: RESOLVED FIXED
: 1089656 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Matthias Brugger
E-mail List
:
Depends on:
Blocks: 1089762
  Show dependency treegraph
 
Reported: 2018-04-16 21:15 UTC by Robert Richter
Modified: 2022-07-21 17:22 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Richter 2018-04-16 21:15:00 UTC
Clone for Tumbleweed:

 https://kernel.opensuse.org/cgit/kernel-source/tree/config/arm64/default?h=stable#n585

+++ This bug was initially created as a clone of Bug #1089762 +++

CONFIG_NR_CPUS is set to 128, but there are systems like ThunderX2 with up to 256 cores.

CONFIG_NR_CPUS should be set to 256 as in Leap 42.3.

See:

 https://kernel.opensuse.org/cgit/kernel-source/tree/config/arm64/default?h=openSUSE-15.0#n536
 https://kernel.opensuse.org/cgit/kernel-source/tree/config/arm64/default?h=openSUSE-42.3#n459

Same for Tumbleweed:

 https://kernel.opensuse.org/cgit/kernel-source/tree/config/arm64/default?h=stable#n585
Comment 1 Andreas Stieger 2018-04-17 08:42:45 UTC
*** Bug 1089656 has been marked as a duplicate of this bug. ***