Bug 1089758 - LoadParm().load_default() fails with "Unable to load default file"
LoadParm().load_default() fails with "Unable to load default file"
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Samba
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: The 'Opening Windows to a Wider World' guys
The 'Opening Windows to a Wider World' guys
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-16 20:13 UTC by David Mulder
Modified: 2019-03-26 19:11 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
On the failing system, param.so is missing links to a number of libraries (4.78 KB, text/plain)
2018-04-16 20:39 UTC, David Mulder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Mulder 2018-04-16 20:13:22 UTC
Python 2.7.14 (default, Oct 12 2017, 15:50:02) [GCC] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from samba.param import LoadParm
>>> lp = LoadParm()
>>> lp.load_default()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
RuntimeError: Unable to load default file

This doesn't happen against TW from a month ago (which I think was using 4.7). I haven't been able to get a backtrace, since the build is failing with a rpc issue.
Comment 1 David Mulder 2018-04-16 20:34:42 UTC
On a TW box built a month ago, I updated to the latest samba in TW (the same version that is failing on my other box), and I *do not* see the failure. So, this failure is someone not related to the samba version, but something else about the environment on the system.
Comment 2 David Mulder 2018-04-16 20:39:28 UTC
Created attachment 767330 [details]
On the failing system, param.so is missing links to a number of libraries
Comment 3 Noel Power 2018-04-17 08:20:52 UTC
(In reply to David Mulder from comment #2)
> Created attachment 767330 [details]
> On the failing system, param.so is missing links to a number of libraries

That might be a red herring, ldd -r -d on the library should show any stuff that is really missing

This whole issue sounds vaguely familiar, is there by any chance a line like

   include = /etc/samba/dhcp.conf 

in your smb.conf file ? If so this seems to make the param module unhappy (which is a bug imho) Comment it out if this is the case as a temporary measure
Comment 4 Samuel Cabrero 2018-04-17 09:02:50 UTC
(In reply to Noel Power from comment #3)
> (In reply to David Mulder from comment #2)
> > Created attachment 767330 [details]
> > On the failing system, param.so is missing links to a number of libraries
> 
> That might be a red herring, ldd -r -d on the library should show any stuff
> that is really missing
> 
> This whole issue sounds vaguely familiar, is there by any chance a line like
> 
>    include = /etc/samba/dhcp.conf 
> 
> in your smb.conf file ? If so this seems to make the param module unhappy
> (which is a bug imho) Comment it out if this is the case as a temporary
> measure

Verified, the issue is produced by including a missing file.
Comment 5 Noel Power 2018-04-17 09:28:25 UTC
(In reply to Samuel Cabrero from comment #4)
> (In reply to Noel Power from comment #3)
> > (In reply to David Mulder from comment #2)
> > > Created attachment 767330 [details]
> > > On the failing system, param.so is missing links to a number of libraries
> > 
> > That might be a red herring, ldd -r -d on the library should show any stuff
> > that is really missing
> > 
> > This whole issue sounds vaguely familiar, is there by any chance a line like
> > 
> >    include = /etc/samba/dhcp.conf 
> > 
> > in your smb.conf file ? If so this seems to make the param module unhappy
> > (which is a bug imho) Comment it out if this is the case as a temporary
> > measure
> 
> Verified, the issue is produced by including a missing file.

yep, that's a more correct way to express it :-) It's not the file, it's the fact it is missing
Comment 6 David Mulder 2018-04-17 12:27:03 UTC
We should stop laying down that setting on join if the file doesn't exist.
Comment 8 Swamp Workflow Management 2019-03-05 13:10:06 UTC
This is an autogenerated message for OBS integration:
This bug (1089758) was mentioned in
https://build.opensuse.org/request/show/681723 Factory / samba
Comment 9 David Mulder 2019-03-26 19:11:40 UTC
Fixed in 4.9.5+