Bug 1088676 - config file paths in manual page wrong
config file paths in manual page wrong
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kubic
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Ignaz Forster
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-09 12:18 UTC by Thorsten Kukuk
Modified: 2021-06-14 06:15 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Kukuk 2018-04-09 12:18:14 UTC
The manual page for transactional-update.conf contains two wrong paths (or better has a /usr too much in front):

/usr/etc/transactional-update.conf
/usr/usr/etc/transactional-update.conf
Comment 1 Ignaz Forster 2018-04-09 13:11:48 UTC
That's actually correct: Both transactional-update itself and the manpages respect the corresponding autoconf installation directory variables ‘sysconfdir’ and ‘prefix’. By default autoconf is using ‘/usr/etc’ and ‘/usr’ for those variables, resulting in the mentioned paths.

As *SUSE will (like almost every other distribution) automatically set ‘sysconfdir’ to ‘/etc’ at configuration time, the documentation in the package will contain "sane" paths.

Because of that I'd propose leaving it as it is - would that be fine with you?
Comment 2 Thorsten Kukuk 2018-04-09 13:20:31 UTC
This are the paths in the manual page from our RPM on openSUSE Tumbleweed/Kubic.
Comment 3 Ignaz Forster 2018-04-09 13:52:12 UTC
The problem is that the manual pages won't be regenerated if docbook is not available, thus the values of the system where `make dist` was called will be used.

We don't have docbook defined as a build dependency, so the safest bet would probably be to just add it and hence to make sure the documentation will always match the build's paths...
Comment 4 Ignaz Forster 2018-10-08 14:48:30 UTC
Up until now configure.ac built documentation if the necessary tools were installed and silently ignored it otherwise, using pre-built documentation files (which in turn contained the paths configured by the person uploading the release).

Those pre-built man and HTML files have been removed, guaranteeing that the documentation will always match the build system's configuration.
For not having to rely on the autodetection an explicit "with(out)-doc" switch was added as a configuration option. If this option is not set an additional warning is printed if the documentation won't be built.
Comment 6 Ignaz Forster 2018-11-22 18:08:35 UTC
Available since Tumbleweed snapshot 20181029.
Comment 7 Swamp Workflow Management 2018-11-23 14:30:34 UTC
This is an autogenerated message for OBS integration:
This bug (1088676) was mentioned in
https://build.opensuse.org/request/show/651388 15.0 / transactional-update
Comment 8 Swamp Workflow Management 2018-12-07 23:09:05 UTC
openSUSE-RU-2018:4027-1: An update that has 6 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1088676,1097619,1105992,1111319,1111321,1111786
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    transactional-update-2.11-lp150.2.9.1
openSUSE Backports SLE-15 (src):    transactional-update-2.11-bp150.2.6.1