Bug 1088562 - [Build 20180406] khelpcenter on livemedia: content looks broken
[Build 20180406] khelpcenter on livemedia: content looks broken
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Live Medium
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Luca Beltrame
E-mail List
https://openqa.opensuse.org/tests/652...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-07 21:55 UTC by Dominique Leuenberger
Modified: 2018-04-24 15:17 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-04-07 21:55:26 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-KDE-Live-x86_64-kde-live@64bit fails in
[khelpcenter](https://openqa.opensuse.org/tests/652287/modules/khelpcenter/steps/4)


## Reproducible

Fails since (at least) Build [20180406](https://openqa.opensuse.org/tests/652287) (current job)


## Expected result

Last good: [20180404](https://openqa.opensuse.org/tests/651424) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?flavor=KDE-Live&distri=opensuse&machine=64bit&version=Tumbleweed&arch=x86_64&test=kde-live)
Comment 1 Fabian Vogt 2018-04-07 22:21:11 UTC
This is due to use of excludedocs AFAICT.

Not sure whether it's worth looking into, it's more or less intentional.
Comment 2 Wolfgang Bauer 2018-04-08 07:21:38 UTC
IIUIC, this could be "fixed" by removing the %doc marker from the corresponding files in kdoctools:
-%doc %{_kf5_htmldir}/*/
+%{_kf5_htmldir]/*/
Comment 3 Luca Beltrame 2018-04-12 07:06:38 UTC
I'm working on the KF 5.45 update, I'll try incorporating the suggestion from Wolfgang.
Comment 4 Wolfgang Bauer 2018-04-12 11:50:13 UTC
Those files in /usr/share/doc/HTML/*/kdoctools5-common/ are not really docs anyway I'd say, rather data files (stylesheets and graphics) "needed" to "properly" display the docs, and licenses.
Comment 5 Dominique Leuenberger 2018-04-24 07:51:21 UTC
(In reply to Luca Beltrame from comment #3)
> I'm working on the KF 5.45 update, I'll try incorporating the suggestion
> from Wolfgang.

Thus assigning to Luca
Comment 6 Ludwig Nussel 2018-04-24 15:10:25 UTC
leap 15 needs a fix too
Comment 7 Fabian Vogt 2018-04-24 15:17:47 UTC
This is not possible with excludedocs, even without %doc the files are marked as %doc due to their installed location.

I suggest removing the khelpcenter test in openQA.