Bug 1087826 - Wrong output in the CLI of yast2-nfs-client
Wrong output in the CLI of yast2-nfs-client
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Ancor Gonzalez Sosa
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-03 06:35 UTC by Ancor Gonzalez Sosa
Modified: 2018-04-03 10:28 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ancor Gonzalez Sosa 2018-04-03 06:35:18 UTC
When using the command line interface of yast2-nfs-client to list the configured NFS mounts, the column "options" does not display the mount options. Instead, it displays the content of the vfstype field.

By the way, vfstype should not longer contain any value different to "nfs", so it makes no sense to display it and the usage of any other value should be discouraged.
Comment 1 Ancor Gonzalez Sosa 2018-04-03 06:37:05 UTC
The bug was introduced ten years ago in this commit, which added vfstype to the UI but didn't update the CLI in consequence:

https://github.com/yast/yast-nfs-client/commit/0769cd55b89237d0588ebeddff416b3f059aba37
Comment 2 Ancor Gonzalez Sosa 2018-04-03 10:28:05 UTC
Fixed in yast2-nfs-client 4.0.4. See https://build.opensuse.org/request/show/593104