Bug 1087796 - Fully updated Tumbleweed image on Raspberry Pi2 halts regularly
Fully updated Tumbleweed image on Raspberry Pi2 halts regularly
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
armv7 Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-02 21:50 UTC by Freek de Kruijf
Modified: 2019-10-25 09:56 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Freek de Kruijf 2018-04-02 21:50:09 UTC
I started a Tumbleweed image from ARM-JeOS-raspberrypi2.armv7l-2018.01.20-Build1.1 and regularly updated it using "zypper dup --no-recommnds" to the latest version. A bluetooth dongle is present in the system. During its lifetime it halts regularly, after days without a problem. Power off and on again restores a working system for a few days. Most of the time there is nothing in the journal to indicate the cause of halting the system. Messages do not appear anymore in the journal.
A few days back I found the following:
mrt 30 17:12:44 smahp kernel: Unable to handle kernel paging request at virtual address 00cfad70
mrt 30 17:12:44 smahp kernel: pgd = c2082d00
mrt 30 17:12:44 smahp kernel: [00cfad70] *pgd=2e689003, *pmd=00000000
mrt 30 17:12:44 smahp kernel: Internal error: Oops: a06 [#1] PREEMPT SMP ARM
mrt 30 17:12:44 smahp kernel: Modules linked in: rfcomm cmac nf_log_ipv6 xt_comment nf_log_ipv4 nf_log_common xt_LOG xt_limit xt_rec
mrt 30 17:12:44 smahp kernel: CPU: 0 PID: 1481 Comm: SBFspotUploadDa Not tainted 4.14.14-1-lpae #1
mrt 30 17:12:44 smahp kernel: Hardware name: BCM2835
mrt 30 17:12:44 smahp kernel: task: c2b2f7c0 task.stack: c2be8000
mrt 30 17:12:44 smahp kernel: PC is at memcpy+0x50/0x330
mrt 30 17:12:44 smahp kernel: LR is at 0x0
mrt 30 17:12:44 smahp kernel: pc : [<c0ceb750>]    lr : [<00000000>]    psr: 200f0013
mrt 30 17:12:44 smahp kernel: sp : c2be9d74  ip : 00000000  fp : c2be9dbc
mrt 30 17:12:44 smahp kernel: r10: dac0a000  r9 : dac0a000  r8 : 00000052
mrt 30 17:12:44 smahp kernel: r7 : 40a9e95f  r6 : 7e30303a  r5 : 35333a38  r4 : 30203332
mrt 30 17:12:44 smahp kernel: r3 : 2d35302d  r2 : 000001f0  r1 : dac0ad80  r0 : 00cfad70
mrt 30 17:12:44 smahp kernel: Flags: nzCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment user
mrt 30 17:12:44 smahp kernel: Control: 30c5387d  Table: 02082d00  DAC: fffffffd
mrt 30 17:12:44 smahp kernel: Process SBFspotUploadDa (pid: 1481, stack limit = 0xc2be8210)
mrt 30 17:12:44 smahp kernel: Stack: (0xc2be9d74 to 0xc2bea000)
mrt 30 17:12:44 smahp kernel: 9d60:                                              00000001 00000ff0 00000010
mrt 30 17:12:44 smahp kernel: 9d80: ffffe000 00cfa010 00cfa010 c083a254 c22317d0 ef865f00 00001000 00001000
mrt 30 17:12:44 smahp kernel: 9da0: c2be9ef0 efbdc168 c2be9ee8 00000000 c2be9dcc c2be9dc0 c083a44c c083a17c
mrt 30 17:12:44 smahp kernel: 9dc0: c2be9ddc c2be9dd0 c083fa90 c083a438 c2be9e1c c2be9de0 c0842f7c c083fa64
mrt 30 17:12:44 smahp kernel: 9de0: ef0de900 c109d43c dac0a000 00cfa010 c04eca08 dcd08d44 c23099c0 efbdc168
mrt 30 17:12:44 smahp kernel: 9e00: 00000e06 c2be9f08 00001000 dcd08c50 c2be9e8c c2be9e20 c05c57d0 c0842d6c
mrt 30 17:12:45 smahp kernel: 9e20: c15158c8 00000000 c2be9e44 014000c0 00080001 00000000 00000e05 00000000
mrt 30 17:12:45 smahp kernel: 9e40: 00000e07 c2309a28 c2be9ef0 00000000 ffffe000 00000000 01bf3fff 00000000
mrt 30 17:12:45 smahp kernel: 9e60: c2be9e8c c2be9f08 00001000 c2be9f78 00cfa010 c2be9f78 00000000 c2be9ef0
mrt 30 17:12:45 smahp kernel: 9e80: c2be9ecc c2be9e90 c05c6c08 c05c55d4 c23099c0 00000000 00001000 00028002
mrt 30 17:12:45 smahp kernel: 9ea0: 00000000 00000000 c23099c0 c2be9f78 00cfa010 c2be9f78 00000000 00000000
mrt 30 17:12:45 smahp kernel: 9ec0: c2be9edc c2be9ed0 c06f352c c05c6ae8 c2be9f44 c2be9ee0 c0652a6c c06f34f4
mrt 30 17:12:45 smahp kernel: 9ee0: 00001000 c069bbf4 00cfa010 00001000 00000000 00000000 00001000 c2be9ee8
mrt 30 17:12:45 smahp kernel: 9f00: 00000001 c2be9f10 c23099c0 00000000 00e06000 00000000 00000000 00000000
mrt 30 17:12:45 smahp kernel: 9f20: 00000000 00000000 ffffe000 00001000 c23099c0 00cfa010 c2be9f74 c2be9f48
mrt 30 17:12:45 smahp kernel: 9f40: c0652b54 c0652994 00000008 c06741d8 c23099c0 c23099c0 00e06000 00000000
mrt 30 17:12:45 smahp kernel: 9f60: 00cfa010 00001000 c2be9fa4 c2be9f78 c06530fc c0652ac4 00e06000 00000000
mrt 30 17:12:45 smahp kernel: 9f80: 00001000 00cfa010 00000007 00000003 c0436ac8 c2be8000 00000000 c2be9fa8
mrt 30 17:12:45 smahp kernel: 9fa0: c04368c0 c06530bc 00001000 00cfa010 00000007 00cfa010 00001000 00000000
mrt 30 17:12:46 smahp kernel: 9fc0: 00001000 00cfa010 00000007 00000003 00000000 00cfa010 00000000 b6edf6f0
mrt 30 17:12:46 smahp kernel: 9fe0: 00000000 bed6edb8 00000000 b6b3b9f0 800f0010 00000007 00000000 00000000
mrt 30 17:12:46 smahp kernel: [<c0ceb750>] (memcpy) from [<c083a254>] (__copy_to_user_memcpy+0xe4/0x18c)
mrt 30 17:12:46 smahp kernel: [<c083a254>] (__copy_to_user_memcpy) from [<c083a44c>] (arm_copy_to_user+0x20/0x34)
mrt 30 17:12:46 smahp kernel: [<c083a44c>] (arm_copy_to_user) from [<c083fa90>] (copyout+0x38/0x48)
mrt 30 17:12:46 smahp kernel: [<c083fa90>] (copyout) from [<c0842f7c>] (copy_page_to_iter+0x21c/0x498)
mrt 30 17:12:46 smahp kernel: [<c0842f7c>] (copy_page_to_iter) from [<c05c57d0>] (generic_file_buffered_read+0x208/0x8b0)
mrt 30 17:12:46 smahp kernel: [<c05c57d0>] (generic_file_buffered_read) from [<c05c6c08>] (generic_file_read_iter+0x12c/0x180)
mrt 30 17:12:46 smahp kernel: [<c05c6c08>] (generic_file_read_iter) from [<c06f352c>] (ext4_file_read_iter+0x44/0x58)
mrt 30 17:12:46 smahp kernel: [<c06f352c>] (ext4_file_read_iter) from [<c0652a6c>] (__vfs_read+0xe4/0x130)
mrt 30 17:12:46 smahp kernel: [<c0652a6c>] (__vfs_read) from [<c0652b54>] (vfs_read+0x9c/0x164)
mrt 30 17:12:46 smahp kernel: [<c0652b54>] (vfs_read) from [<c06530fc>] (SyS_read+0x4c/0xa4)
mrt 30 17:12:46 smahp kernel: [<c06530fc>] (SyS_read) from [<c04368c0>] (ret_fast_syscall+0x0/0x4c)
mrt 30 17:12:46 smahp kernel: Code: f5d1f05c f5d1f07c e8b151f8 e2522020 (e8a051f8)

I have another Raspberry Pi2 system starting with the same image and also regularly updated with "zypper dup --no-recommends", which never did halt. Only this one does not have a bluetooth dongle.
Comment 1 Jiri Slaby 2018-06-15 12:15:49 UTC
Does this happen also with 4.17?
Comment 2 Freek de Kruijf 2018-06-15 12:56:31 UTC
(In reply to Jiri Slaby from comment #1)
> Does this happen also with 4.17?

I updated the system using "zypper dup --no-r" and only two so-called downgrades are performed.
# uname -a
Linux smahp 4.16.6-1-lpae #1 SMP PREEMPT Mon Apr 30 20:33:51 UTC 2018 (566acbc) armv7l armv7l armv7l GNU/Linux
So the kernel does not use 4.17 at the moment.

I am using a newer kernel, than the one I complained about, about 1 month ago, which did not show the problematic behavior. However a few days ago I found the system in a problematic state. In that state processes stayed active while they should not stay active for 230 seconds. The process is started with "timeout 230s". After that I now use "timeout -k 30s 230s" to start the process each 5 minutes. It should finish normally in a few seconds, but when there is no connection via bluetooth this process should finish in about 1 minute.

Previously I could not enter the system via ssh in a problematic state, whereas in the problematic state of above I was able to enter via ssh. This allowed me to see these many processes, around 30, hanging around. I hope "-k 30s" will prevent this in future.

So maybe the original problem was caused by this program of which too many processes stayed hanging around.
I make a log of the exit state of the timeout command, so I can monitor the behavior of this program.
Comment 3 Jiri Slaby 2019-10-25 09:56:52 UTC
There happened a lot since 4.16. So if you still encounter the bug with 5.3, please reopen with a fresh backtrace.