Bug 1087710 - [Build 20180330] openQA test fails in btrfs_autocompletion
[Build 20180330] openQA test fails in btrfs_autocompletion
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Patterns
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dominique Leuenberger
E-mail List
https://openqa.opensuse.org/tests/647...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-01 01:43 UTC by Dominique Leuenberger
Modified: 2021-11-03 20:45 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2018-04-01 01:43:21 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_filesystem@64bit fails in
[btrfs_autocompletion](https://openqa.opensuse.org/tests/647209/modules/btrfs_autocompletion/steps/4)


## Reproducible

Fails since (at least) Build [20180330](https://openqa.opensuse.org/tests/646987)


## Expected result

Last good: [20180329](https://openqa.opensuse.org/tests/646126) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?machine=64bit&test=extra_tests_filesystem&flavor=DVD&version=Tumbleweed&arch=x86_64&distri=opensuse)

btrfs/bash completion is failing.

There is likely something more basic broken than btrfs, as there are other bash syntax related failures popping up in this snapshot, that might have similar root causes
Comment 1 Dominique Leuenberger 2018-04-03 10:55:40 UTC
Turns out the presence of bash-completion was a mere 'accident' and not a conscious decision.

Until recently, systemd had the bash completion split out into a systemd-bash-completion subpackage, which was recommended by systemd (zsh completion was part of the main package); systemd-bash-completion, in turn, required bash-completion (which makes sense)

As the subpackage per se makes no sense, systemd-bash-completion was merged into systemd; the recommends/requires on bash-completion was not move to systemd though (this would be wrong, since not all systemd users are required to use bash)

So, the consequence of this change is bash-completion is no longer installed on a default installation (as it was not present by conscious decision to start with) - and this, in turn, breaks the openQA test, that expects bash-completion to work without further doing.

Changing to 'pattern' - as there is nothing else that would make sense to consider adding bash-completion.
Comment 2 Swamp Workflow Management 2018-04-03 11:40:05 UTC
This is an autogenerated message for OBS integration:
This bug (1087710) was mentioned in
https://build.opensuse.org/request/show/593175 Factory / patterns-base
Comment 3 Dominique Leuenberger 2018-04-24 07:55:37 UTC
(In reply to Swamp Workflow Management from comment #2)
> This is an autogenerated message for OBS integration:
> This bug (1087710) was mentioned in
> https://build.opensuse.org/request/show/593175 Factory / patterns-base

Fix commited