Bug 1087693 - poor login behavior/interaction with software updates *and* network manager in KDE
poor login behavior/interaction with software updates *and* network manager i...
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-31 00:46 UTC by Jon Nelson
Modified: 2019-04-03 17:51 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Nelson 2018-03-31 00:46:02 UTC
After upgrading to Tumbleweed recently, I've encountered a strange problem.
On login (but not screen unlock), two things have happened:

1. the software updater has tried to update (before a network is connected to). Since this results in an error, there is an error notification to dismiss.  Why it tried to do something despite network manager saying there is no network is also an issue.

2. the other issue is that network manager is trying to connect, but it's saying that it's waiting for authorization, however I've not seen any kwallet request. If I manually re-select the same or a different network, *then* I get an authorization request dialog and things process more or less normally.
Comment 1 Wolfgang Bauer 2019-04-03 17:51:52 UTC
Please don't report multiple issues in one bug report.

#1 should be fixed meanwhile (see bug 1103678).

#2 is basically an upstream issue in NetworkManager and only happens if you use a user connection and store the password in the user account. (storing the password system-wide should be a workaround to avoid that)
That's a duplicate of bug 971540 though.

I'm closing this one as invalid, as I can't decide which one I should mark this as duplicate of...